POJ 2096 Collecting Bugs (概率DP)

Collecting Bugs
Time Limit: 10000MS   Memory Limit: 64000K
Total Submissions: 4038   Accepted: 2013
Case Time Limit: 2000MS   Special Judge

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program. 
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category. 
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version. 
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem. 
Find an average time (in days of Ivan's work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000

Source

Northeastern Europe 2004, Northern Subregion

題目鏈接:點擊打開題目鏈接

題意:一個程序有s個子系統,n種bug,一天發現一個bug,這個bug出現在每個子系統的概率相同且不會同時屬於兩個子系統,同理,是每種bug的概率相同。求發現每個子系統至少一個bug,每種bug至少一個的天數期望。

思路:dp[i][j]表示i個子系統出現bug,且共發現j種bug時達到目標狀態的天數期望。dp[s][n]=0;

             狀態轉移方程:

             接下來發現的bug有四種可能:

             屬於一個新的子系統,是一種新bug,概率p1=(1-i/s)*(1-j/n);

             屬於一個新的子系統,不是一種新bug,概率p2=(1-i/s)*j/n;

             不屬於一個新的子系統,是一種新bug,概率p3=i/s*(1-j/n);

             不屬於一個新的子系統,不是一種新bug,概率p4=/s*j/n;

             dp[i][j]=p1*(dp[i+1][j+1]+1)+p2*(dp[i+1][j]+1)+p3*(dp[i][j+1]+1)+p4*(dp[i][j]+1);

            化簡得dp[i][j]=(1+p1*dp[i+1][j+1]+p2*dp[i+1][j]+p3*dp[i][j+1])/(1-p4);

代碼:

#include<stdio.h>
#include<string.h>
double dp[1010][1010];
int main()
{
    int n,s,i,j;
    while(scanf("%d%d",&n,&s)!=EOF)
    {
    dp[n][s]=0;
    for(i=n;i>=0;i--)
    for(j=s;j>=0;j--)
    {
        if(i==n&&j==s) continue;
        dp[i][j]=1.0*((n-i)*(s-j)*dp[i+1][j+1]+i*(s-j)*dp[i][j+1]+n*s+(n-i)*j*dp[i+1][j])/(n*s-i*j);//避免損失精度分子分母同乘以n*s
    }
    printf("%.4lf\n",dp[0][0]);
    }
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章