HDOJ~~A + B Problem II



A + B Problem II  


 Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)

 Problem Description
 
 
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. 

  Input
 
 The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000. 
  
  Output
 
  For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases. 
  
  Sample Input
 2
1 2
112233445566778899 998877665544332211

  
  Sample Output
 
 Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

#include<stdio.h>
#include<string.h>
#define MAX 1001
int main()
{
 int n;
 char num1[MAX],num2[MAX],num3[MAX];
 //num3用來保存結果
 scanf("%d",&n);
 for(int t=0;t<n;t++)
 {
  if(t)
  printf("\n");
  scanf("%s %s",num1,num2);
  //獲取兩個數字的位數
  int len1=strlen(num1);
  int len2=strlen(num2);
  int len3=0;
  memset(num3,'0',sizeof(num3));
  //按位相加,先不管進位
  for(int i=len1-1,j=len2-1;i>=0&&j>=0;i--,j--)
  {
   num3[len3++]=num1[i]+num2[j]-'0';
   //如果有一個數組先爲空,則把另一個數組裏剩下的數字放入num3[]中
   if(i==0)
   while(j--) num3[len3++]=num2[j];
   else if(j==0)
   while(i--) num3[len3++]=num1[i];  
  } //進位處理
  for(int i=0;i<len3;i++)
  {
   if(num3[i]>'9')
   {
    num3[i+1]+=(num3[i]-'0')/10;
   }
  } //格式輸出
  for(int i=MAX-1;i>=0;i--)
  {
   if(num3[i]!='0')
   {
    printf("Case %d:\n",t+1);
    printf("%s + %s =",num1,num2);
    while(i>=0) printf("%c",num3[i--]);
    printf("\n");
   }
  } 
 }
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章