HDU 1496 Equation 哈希

Equations

Time Limit: 3000 MS Memory Limit: 32768 KB

64-bit integer IO format: %I64d , %I64u Java class name: Main

[Submit] [Status] [Discuss]

Description

Consider equations having the following form: 

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.

Input

The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.

Output

For each test case, output a single line containing the number of the solutions.

Sample Input

1 2 3 -4
1 1 1 1

Sample Output

39088
0
     利用題中的公式求解出答案;如果是四個for 的話會超時,所以想到了用哈希;再把公式拆成倆個部分,a*i*i + b*j*j 與 -c*i*i - d*j*j  使這倆個數相等即可;再多用一個數組去存負數的情況;並且在a,b,c,d 同號時答案爲零(樣例1,1,1,1);



#include<stdio.h>
#include<iostream>
#include<string.h>
#define maxn 1000000     //最大值
using namespace std;
int Hash1[maxn];
int Hash2[maxn];
int i,j,ans;
int main()
{
    int a,b,c,d;
    while(scanf("%d%d%d%d",&a,&b,&c,&d)!=EOF)
    {
        memset(Hash1,0,sizeof(Hash1));
        memset(Hash2,0,sizeof(Hash2));
        if(a*b>0 && b*c>0 && c*d>0)          //同號答案0;
        {
            printf("0\n");
            continue;
        }
        for(i=1;i<=100;i++)                       
        {
            for(j=1;j<=100;j++)
            {
                int n = a*i*i+b*j*j;
                if(n>0) Hash1[n]++;       //用Hash1這個數組存正數;
                else Hash2[-n]++;         // 用Hash2來存負數,注意是 -n;
            }
        }
        ans = 0;
        for(i=1;i<=100;i++)
        {
            for(j=1;j<=100;j++)
            {
                int n = -c*i*i-d*j*j;
                if(n>0) ans+=Hash1[n];     //當n大於0時,把代表爲正的數組加起來;

                else ans+=Hash2[-n];        //當n小於0時,把負值相加;
            }
        }
        printf("%d\n",16*ans);              //由於是平方,所以這4個值都有2種情況(不論 i 值正負 i*i 值都一樣),所以要總數要乘16;
    }
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章