[DP] POJ-2533 Longest Ordered Subsequence

Longest Ordered Subsequence
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 55238 Accepted: 24770

Description

A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

題意:給n個數,求出最長不下降子序列

//已AC代碼
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cstring>

using namespace std;

int a[10880];
int dp[10880];

int main()
{
    int n;

    while(scanf("%d",&n)!=EOF)
    {

        memset(a,0,sizeof(a));
        memset(dp,0,sizeof(dp));
        int keep=0;
        for(int i=1;i<=n;i++)
        {
             cin>>a[i];
        }
        for(int i=1;i<=n;i++)
        {
            dp[i]=1;
            for(int j=1;j<=i;j++)
            {
                if(a[i]>a[j])
                {
                    dp[i]=max(dp[i],dp[j]+1);

                }
            }
        }
        for (int i=1;i<=n;i++)
        {
            keep=max(keep,dp[i]);
        }

        cout<<keep<<endl;
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章