hdu2594Simpsons’ Hidden Talents(kmp,next)

Simpsons’ Hidden Talents

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2203    Accepted Submission(s): 827


Problem Description
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
 

Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
 

Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.
 

Sample Input
clinton homer riemann marjorie
 

Sample Output
0 rie 3
 

我的版本

#include <iostream>
#include <cstring>
#include <string>
using namespace std;
const int MAXN = 50005;
int next[MAXN];
string text,pattern;
char tep[MAXN];

void get_next(){
    next[0]=next[1]=0;
    int m = pattern.size();
    for(int i=1; i<m; i++){
        int j=next[i];
        while(j && pattern[i]!=pattern[j]) j=next[j];
        next[i+1]=(pattern[i]==pattern[j]? j+1 : 0);
    }
}

void kmp(){
    int maxLen=0;
    int maxIndex=0;
    int n = text.size();
    int m = pattern.size();
    int j = 0;
    for(int i=0; i<n; i++){
        while(j && text[i]!=pattern[j]) j=next[j];
        if(text[i]==pattern[j]) j++;
        if(j==m && i!=n-1){ //如果s1匹配完畢,但是並沒有對齊s2的後綴,則滾回s1首次對齊的位置重新搜索,不過這樣效率比較低,遇到極端數據就不好說了
            i=i-j+1;
            maxLen=0;
            j=0;
        }
        maxLen=j;
    }
    if(maxLen>0) cout<<text.substr(n-1-maxLen+1)<<" "<<maxLen<<endl;
    else cout<<0<<endl;
}

int main()
{
    while(cin>>pattern>>text){
        get_next();
        kmp();
    }
    return 0;
}


看了別人的思路,考察的是next數組的認識。

http://blog.csdn.net/chenguolinblog/article/details/8126286

思路:kmp+next數組的應用

分析:
1 題目要求的是給定兩個字符串s1 , s2找到s1的最長前綴等於s2的後綴
2 很明顯就是next數組的應用,我們知道next[j] = len,表示的前j個字符裏面前綴和後綴的最長匹配長度爲len。那麼我們只要合併兩個字符串然後求next數組即可。
3 注意以下的數據
abcabcabcabc
abcabcabcabcabc
輸出 12
abcabc
abc
輸出 3

我們知道如果合併了s1和s2的話,那麼求出來的最長的長度是24 和 6顯然是不行的,因爲我們忽略了一個地方就是求出的最長的前綴的長度是不能超過
s1和s2的長度的,所以求出最長前綴長度後應該進行討論。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;

#define MAXN 100010

char s1[MAXN/2];
char s2[MAXN/2];
char pattern[MAXN];
int next[MAXN];

void getNext(){
    int n = strlen(s1);
    int m = strlen(s2);
    next[0] = next[1] = 0;
    for(int i = 1 ; i < n+m ; i++){
       int j = next[i];
       while(j && pattern[i] != pattern[j])
           j = next[j];
       next[i+1] = pattern[i] == pattern[j] ? j+1 : 0;
    }
    if(!next[n+m])
      printf("0\n");
    else{
      int tmp = next[m+n];
      s1[tmp] = '\0';
      if(n > m){/*如果第一串大於第二串*/
        if(tmp > m)/*如果tmp>第二串長度直接輸出第二串*/
          printf("%s %d\n" , s2 , m);
        else
          printf("%s %d\n" , s1 , tmp);
      }
      else{/*如果第一串小於第二串*/
        if(tmp > n)/*如果tmp>第一串的長度直接輸出第一串*/
          printf("%s %d\n" , s1 , n);
        else
          printf("%s %d\n" , s1 , tmp);
      }
    }
}

int main(){
   while(scanf("%s" , s1) != EOF){
       scanf("%s" , s2);
       memcpy(pattern , s1 , sizeof(s1));
       strcat(pattern , s2);
       getNext();
   }
   return 0;
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章