BoneCollector-01揹包

問題來源:hdu-2602

Bone Collector


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input
The first line contain a integer T , the number of cases.Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 
Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output
14

源代碼:
#include<stdio.h>
#include<string.h>
#define MAX 1002

int  V , N , pack[MAX];
int  volume[MAX] , value[MAX];

int Max( int a , int b ){ return a >= b ? a : b; }
int ZeroOnePack( void );    //0-1揹包

int main( ){
    int T;

    scanf("%d",&T);

    while( T-- ){
        scanf("%d%d",&N,&V);

        for( int i=0 ; i<N ; i++ )
            scanf("%d",&value[i]);

        for( int i=0 ; i<N ; i++ )
            scanf("%d",&volume[i]);

        printf("%d\n",ZeroOnePack());
    }

    return 0;
}


int ZeroOnePack( void ){
    memset( pack , 0  , sizeof( pack ) );
    //初始化爲0是揹包不要求放滿的情況
    //當揹包要求放滿的話,需要初始化爲-INF(初始都不滿),pack[0]=0(理解爲0容量的揹包已經滿了)

    for( int i=0 ; i<N ; i++ )
        for( int j=V ; j-volume[i]>=0 ; j-- )    //01揹包從後向前dp,完全揹包從前向後dp,保證了i物品不會被選擇多次
            pack[j] = Max( pack[j] , pack[j-volume[i]]+value[i] );
    return pack[V];    //返回揹包能容納的物品最大價值
}

代碼分析:該題是很明顯的揹包題,具體是0-1揹包,即每個物品最多隻能選擇一次,所以ZeroOnePack函數的第二層從後往前循環保證了這一點,若從頭往後循環則是完全揹包問題。同時注意初始化的時候全都賦值爲0是不要求放滿的情況,若需要放滿,則賦值爲pack[i]=-INF&&pack[0]=0;
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章