ZOJ 1610 Count the Colors(線段樹,但暴力未必不行)

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1610



Description
Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.

Your task is counting the segments of different colors you can see at last.

Input

The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.

Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.

Output

Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.

If some color can’t be seen, you shouldn’t print it.

Print a blank line after every dataset.

Sample Input

5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1

Sample Output

1 1
2 1
3 1

1 1

0 2
1 1


題解:暴力就好。只要120MS


<span style="font-size:18px;">#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=8001;
int a[maxn],b[maxn],n,l,r,c;
int main()
{
    while(cin>>n)
    {
        memset(a,-1,sizeof(a));
        memset(b,0,sizeof(b));
        for(int i=0;i<n;i++){
            cin>>l>>r>>c;
            for(int i=l;i<r;i++) a[i]=c;
        }
        if(a[0]!=-1) b[a[0]]++;
        for(int i=1;i<maxn;i++)
        {
            if(a[i]!=a[i-1]&&a[i]!=-1)
                b[a[i]]++;
        }
        for(int i=0;i<maxn;i++)
        {
            if(b[i]>0) cout<<i << " " << b[i] << endl;
        }
        cout<<endl;
    }
    return 0;
}</span>





 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章