Pat(Advanced Level)Practice--1089(Insert or Merge )

Pat1089代碼

題目描述:

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10

3 1 2 8 7 5 9 4 6 0

1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort

1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10

3 1 2 8 7 5 9 4 0 6

1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort

1 2 3 8 4 5 7 9 0 6

AC代碼:
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#define MAXN 105

using namespace std;

int original[MAXN],temp[MAXN],ans[MAXN];
int n;

bool isEqual(int a[],int b[]){
	for(int i=0;i<n;i++){
		if(a[i]!=b[i])
			return false;
	}
	return true;
}

void output(int a[]){
	printf("%d",a[0]);
	for(int i=1;i<n;i++)
		printf(" %d",a[i]);
	printf("\n");
}

bool isInsert(){
	int flag=0;
	for(int i=2;i<=n;i++){
		if(flag&&!isEqual(ans,temp)){
			printf("Insertion Sort\n");
			output(ans);
			return true;
		}
		sort(ans,ans+i);
		if(isEqual(ans,temp))
			flag=1;
	}
	return false;
}

bool isMerge(){
	int flag=0;
	int i=0,j=0;
	for(i=2;i<=n;i=i*2){
		for(j=0;j+i<=n;j=j+i){
			if(isEqual(original,temp))
				flag=1;
			sort(original+j,original+j+i);
		}
		sort(original+j,original+n);//remaining sublist which has less than i elements
		if(isEqual(original,temp))
			flag=1;
		if(flag&&!isEqual(original,temp)){
			printf("Merge Sort\n");
			output(original);
			return true;
		}
	}
	return false;
}

int main(int argc,char *argv[]){
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		scanf("%d",&original[i]);
		ans[i]=original[i];
	}
	for(int i=0;i<n;i++)
		scanf("%d",&temp[i]);
	if(!isInsert())
		isMerge();
	return 0;
}

另一種方法:一種直觀的解法,可以分別寫出插入排序和歸併排序,然後比較每一次迭代後的順序;
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章