Pat(Advanced Level)Practice--1084(Broken Keyboard)

Pat1084代碼

題目描述:

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or "_" (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:
7_This_is_a_test
_hs_s_a_es
Sample Output:
7TI

AC代碼:
#include<cstdio>
#include<cstdlib>
#include<map>
#define MAXN 100

using namespace std;

void featureNormalize(char str[]){
	for(int i=0;str[i]!='\0';i++){
		if(str[i]>='a'&&str[i]<='z'){
			str[i]=str[i]-'a'+'A';
		}
	}
}

int main(int argc,char *argv[]){
	char stdInput[MAXN];
	char factInput[MAXN];
	map<char,int> m;
	scanf("%s",stdInput);
	scanf("%s",factInput);
	featureNormalize(stdInput);
	featureNormalize(factInput);
	for(int i=0;factInput[i]!='\0';i++){
		char key=factInput[i];
		m[key]++;
	}
	for(int i=0;stdInput[i]!='\0';i++){
		char key=stdInput[i];
		if(m[key]==0){
			printf("%c",key);
			m[key]++;
		}
	}
	printf("\n");
}

發佈了253 篇原創文章 · 獲贊 26 · 訪問量 33萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章