Convert QWERTY to Dvorak

Edward, a poor copy typist, is a user of the Dvorak Layout. But now he has only a QWERTY Keyboard with a broken Caps Lock key, so Edward never presses the broken Caps Lock key. Luckily, all the other keys on the QWERTY keyboard work well. Every day, he has a lot of documents to type. Thus he needs a converter to translate QWERTY into Dvorak. Can you help him?

The QWERTY Layout and the Dvorak Layout are in the following:

Qwerty Layout
The QWERTY Layout

Dvorak Layout
The Dvorak Layout

Input

A QWERTY document Edward typed. The document has no more than 100 kibibytes. And there are no invalid characters in the document.

Output

The Dvorak document.

Sample Input

Jgw Gqm Andpw a H.soav Patsfk f;doe
Nfk Gq.d slpt a X,dokt vdtnsaohe
Kjd yspps,glu pgld; aod yso kd;kgluZ
1234567890
`~!@#$%^&*()}"']_+-=ZQqWEwe{[\|
ANIHDYf.,bt/
ABCDEFuvwxyz

Sample Output

Hi, I'm Abel, a Dvorak Layout user.
But I've only a Qwerty keyboard.
The following lines are for testing:
1234567890
`~!@#$%^&*()+_-={}[]:"'<>,.?/\|
ABCDEFuvwxyz
AXJE>Ugk,qf;


題意:輸入第一個表的字符,輸出對應下表的字符
思路:打表
#include<stdio.h>
#include<string.h>
char str[96][2]={ 
{'-','['},{'_','{'},{'+','}'},{'=',']'},{'Q','"'},
{'q','\''},{'W','<'},{'w',','},{'E','>'},{'e','.'},
{'R','P'},{'r','p'},{'T','Y'},{'t','y'},{'Y','F'},
{'y','f'},{'U','G'},{'u','g'},{'I','C'},{'i','c'},
{'O','R'},{'o','r'},{'P','L'},{'p','l'},{'{','?'},
{'[','/'},{'}','+'},{']','='},{'S','O'},{'s','o'},
{'D','E'},{'d','e'},{'F','U'},{'f','u'},{'G','I'},
{'g','i'},{'H','D'},{'h','d'},{'J','H'},{'j','h'},
{'K','T'},{'k','t'},{'L','N'},{'l','n'},{':','S'},
{';','s'},{'"','_'},{'\'','-'},{'Z',':'},{'z',';'},
{'X','Q'},{'x','q'},{'C','J'},{'c','j'},{'V','K'},
{'v','k'},{'B','X'},{'b','x'},{'N','B'},{'n','b'},
{'<','W'},{',','w'},{'>','V'},{'.','v'},{'?','Z'},
{'/','z'},{'~','~'},{'`','`'},{'!','!'},{'1','1'},
{'@','@'},{'2','2'},{'#','#'},{'3','3'},{'$','$'},
{'4','4'},{'%','%'},{'5','5'},{'^','^'},{'6','6'},
{'&','&'},{'7','7'},{'*','*'},{'8','8'},{'(','('},
{'9','9'},{')',')'},{'0','0'},{'M','M'},{'m','m'},
{'A','A'},{'a','a'}, {'|','|'},{'\\','\\'},{' ',' '}            
             };

int main()
{
  char s[102500];
  int i,j;
  while(gets(s))
  {
    int len=strlen(s);              
     for(i=0;i<len;i++)
     {
       for(j=0;j<96;j++)
       if(s[i]==str[j][0]) printf("%c",str[j][1]);                  
     }
     printf("\n");
  }    
return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章