Ping pong

 Ping pong

Description

Download as PDF

N(3$ \le$N$ \le$20000) ping pong players live along a west-east street(consider the street as a line segment). Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other ping pong players and hold the game in the referee's house. For some reason, the contestants can't choose a referee whose skill rank is higher or lower than both of theirs. The contestants have to walk to the referee's house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call two games different. Now is the problem: how many different games can be held in this ping pong street?

Input

The first line of the input contains an integer T(1$ \le$T$ \le$20) , indicating the number of test cases, followed by T lines each of which describes a test case.

Every test case consists of N + 1 integers. The first integer is N , the number of players. Then N distinct integers a1a2...aN follow, indicating the skill rank of each player, in the order of west to east ( 1$ \le$ai$ \le$100000 , i = 1...N ).

Output

For each test case, output a single line contains an integer, the total number of different games.

Sample Input

1
3 1 2 3

Sample Output

1


思路:  採用前綴和,後綴和得到結果
        再求前綴和,後綴和的時候後用樹狀數組算法得出來。
       
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int n,a[20005],c[20005],d[20005];
int e[200005]; 
inline int lowbit(int x)
{
  return x&(-x);//2^k
}

int sum(int x) //求前 N項的和  
  {
    int r=0;
	while(x>0)
	{
	 r+=e[x];
	 x-=lowbit(x);
	}
	return r;
  }
void add(int x,int d)//求前 N項sum的和  
  {
    while(x<=100000)
	{
	  e[x]+=d;x+=lowbit(x);
	}
  }


int main()
{
  int t,i;
  scanf("%d",&t);
  while(t--)
  {
    scanf("%d",&n);
    memset(a,0,sizeof(a));
    memset(c,0,sizeof(c));
    memset(d,0,sizeof(d));
    memset(e,0,sizeof(e));
	for(i=1;i<=n;i++)
	  scanf("%d",&a[i]);
	for(i=1;i<=n;i++)//前綴和 
	{
	  add(a[i],1);//求前 N項sum的和  
	  c[i]=sum(a[i]-1);//求前 N項的和  
	}
      memset(e,0,sizeof(e));
	for(i=n;i>=1;i--)//後綴和 
	{
	  add(a[i],1);
	  d[i]=sum(a[i]-1);
	}
	long long ans=0;
	for(i=2;i<n;i++)
		ans+=(long long)c[i]*(n-i-d[i])+(long long)d[i]*(i-1-c[i]);
	printf("%lld\n",ans);
  }
  return 0;
}



發佈了90 篇原創文章 · 獲贊 2 · 訪問量 5萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章