Min Number

Now you are given one non-negative integer n in 10-base notation, it will only contain digits ('0'-'9'). You are allowed to choose 2 integers i and j, such that: i!=j, 1≤i<j≤|n|, here |n| means the length of n’s 10-base notation. Then we can swap n[i] and n[j].

For example, n=9012, we choose i=1, j=3, then we swap n[1] and n[3], then we get 1092, which is smaller than the original n.

Now you are allowed to operate at most M times, so what is the smallest number you can get after the operation(s)?

Please note that in this problem, leading zero is not allowed!

Input

The first line of the input contains an integer T (T≤100), indicating the number of test cases.

Then T cases, for any case, only 2 integers n and M (0≤n<10^1000, 0≤M≤100) in a single line.

Output

For each test case, output the minimum number we can get after no more than M operations.

Sample Input

3
9012 0
9012 1
9012 2

Sample Output

9012
1092
1029

題意:

輸入一個數,和n操作步數

交換n次操作步數,使這個數儘可能的變小

注意:第一個數字不能爲0


#include<stdio.h>
#include<string.h>
int main()
{
int i,j,t,n,mini,x,len;
char str[1004],min;
while(scanf("%d",&t)!=EOF)
{
  getchar();
  while(t--)
  {
   scanf("%s%d",str,&n);
   len=strlen(str);         
   for(i=0;i<len;i++)
    {
      if(n==0) break;
      min=str[i];x=mini=i;
      for(j=i+1;j<len;j++)               
       {
         if(i==0)//考慮第一個不爲0 
          {
            if(min>str[j]&&str[j]!='0') {mini=j;min=str[j];}       
          }                                
         else if(min>str[j]){mini=j;min=str[j];}
       }   
       int k;             
       if(mini!=x) {k=str[mini];str[mini]=str[x];str[x]=k;n--;}
    }          
    printf("%s\n",str);
  }                          
}    
return 0;
}






發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章