uva 10566 Crossed ladders(二分 + 幾何)

Crossed ladders

Time Limit: 1000ms
Memory Limit: 32768KB

A narrow street is lined with tall buildings. An x foot long ladder is rested at the base of the building on the right side of the street and leans on the building on the left side. A y foot long ladder is rested at the base of the building on the left side of the street and leans on the building on the right side. The point where the two ladders cross is exactly c feet from the ground. How wide is the street?


Input

Each line of input contains three positive floating point numbers giving the values of x, y, and c.

Output

For each line of input, output one line with a floating point number giving the width of the street in feet, with three decimal digits in the fraction.

Sample Input

30 40 10
12.619429 8.163332 3
10 10 3
10 10 1

Sample Output

26.033
7.000
8.000

9.798

第一次做二分加幾何的題目,心裏很激動啊,可惜比賽的時候一直在能直接得到答案的幾何關係

#include <cmath>
#include <cstdio>
#include <cstring>
#include <iostream>
#define eps 1e-9
using namespace std;

double x,y,c;

double Binary_search(double mid){
    return 1-c/sqrt(x*x-mid*mid)-c/sqrt(y*y-mid*mid);
}

int main(){
    double l,r,mid;
    while(cin>>x>>y>>c){
        l=0.00;
        r=min(x,y);
        while(r-l>eps){
            mid=(l+r)/2;
            if(Binary_search(mid)>0)
                l=mid;
            else
                r=mid;
        }
        printf("%.3lf\n",mid);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章