Oulipo

he French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book: 

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais… 

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces. 

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap. 

InputThe first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format: 

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W). 
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000. 
OutputFor every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T. 

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3

0

題目意思:給你一個子串,求該子串在主串中出現的次數。

解題思路:利用kmp,不斷匹配,匹配到了計數器就加1,但是這個題我第一次寫超時了,因爲一次匹配成

功後,我就將n置爲0,讓主串倒退到上一個出現子串開頭的地方。

後來改進了一下,主串其實不用倒退,只需將子串倒退到next[n]的位置,即可!

#include<iostream>
#include<cstring>

using namespace std;

int const maxn=1000005;

char str[maxn],str1[maxn];
int next1[maxn];
int len,len1;

void sign()
{
	
	int i,j;
	next1[0]=-1;
	i=-1,j=0;
	int len1=strlen(str1);
	while(j<len1)
	{
	    if(i==-1||str1[i]==str1[j])
	    {
	    	i++;
	    	j++;
	    	next1[j]=i;
		}
		else
		{
			i=next1[i];
		}
	}	
}

int kmp()
{
	int m=0,n=0,num=0;
	int len=strlen(str);
	int len1=strlen(str1);
	sign();
	while(m<len)
	{
		if(n==-1||str[m]==str1[n])
		{
		    m++;
			n++;
		}
		else
		{
			n=next1[n];
		}
		if(n==len1)
		{
			n=next1[n];
			num++;
		}
	}
	return num;
}


int main()
{
	int T;
	cin>>T;
	while(T--)
	{
		scanf("%s",str1);   //子串
		scanf("%s",str);    //主串
		int num1=kmp();
		cout<<num1<<endl;	 
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章