Clairewd’s message

Clairewd is a member of FBI. After several years concealing in BUPT, she intercepted some important messages and she was preparing for sending it to ykwd. They had agreed that each letter of these messages would be transfered to another one according to a conversion table. 
Unfortunately, GFW(someone's name, not what you just think about) has detected their action. He also got their conversion table by some unknown methods before. Clairewd was so clever and vigilant that when she realized that somebody was monitoring their action, she just stopped transmitting messages. 
But GFW knows that Clairewd would always firstly send the ciphertext and then plaintext(Note that they won't overlap each other). But he doesn't know how to separate the text because he has no idea about the whole message. However, he thinks that recovering the shortest possible text is not a hard task for you. 
Now GFW will give you the intercepted text and the conversion table. You should help him work out this problem. 
InputThe first line contains only one integer T, which is the number of test cases. 
Each test case contains two lines. The first line of each test case is the conversion table S. Sii is the ith latin letter's cryptographic letter. The second line is the intercepted text which has n letters that you should recover. It is possible that the text is complete. 
Hint
Range of test data: 
T<= 100 ; 
n<= 100000; 
OutputFor each test case, output one line contains the shorest possible complete text. Sample Input
2
abcdefghijklmnopqrstuvwxyz
abcdab
qwertyuiopasdfghjklzxcvbnm
qwertabcde
Sample Output
abcdabcd

qwertabcde

題目意思:題目看了好久,很難理解,看的莫名奇妙哭

題目就是讓你通過一個密文轉換表,將給出得一個串“密文+明文”(密文是完整的,但明文

未知)補全。

解題思路:理解了題目意思就好寫了,一道kmp的題,其實密文和明文構成了一種映射的關係,在轉換表

中是一一對應的,於是可以先將整個串轉換成“明文”,然後與原串比較,重合的部分的長度

就是密文的長度,然後輸出就行;

#include<iostream>
#include<cstring>

using namespace std;

int const maxn=100005;


char str[maxn],str1[maxn];
int next1[maxn];
int len,len1,mark,Max;

void sign(char *str1,int next1[])
{
	int i,j;
	next1[0]=-1;
	i=-1,j=0;
	int len1=strlen(str1);
	while(j<len1-1)
	{
	    if(i==-1||str1[i]==str1[j])
	    {
	    	i++;
	    	j++;
	    	next1[j]=i;
		}
		else
		{
			i=next1[i];
		}
	}	
}

int kmp(char *str,char *str1)
{
	int m=0,n=0;
	sign(str1,next1);
	int len=strlen(str);
	int len1=strlen(str1);
	if(len%2==0)
	{
		m=len/2;
	}
	else
	{
		m=len/2+1;
	}
	while((m<len)&&(n<len1))
	{
		if(n==-1||str[m]==str1[n])
		{
			m++;
			n++;
		}
		else
		{ 
			n=next1[n];
		}	
	}
	return n;
}


int main()
{
	char s,ss,strm[maxn],strm1[maxn];
	int T;
	cin>>T;
	while(T--)
	{
		scanf("%s",strm);    //轉換表
		scanf("%s",str);    //密文+明文 
		for(int i=0;i<26;i++)
		{
			s=strm[i];
			strm1[s]=i;         //轉換表中每一字母與26個字母一一對應 
		}
		int lenn=strlen(str);
		for(int i=0;i<lenn;i++)
		{
			ss=strm1[str[i]];   //密文的每一個字母在26個字母中的位置 
	        str1[i]='a'+ss;      //ASCII轉換爲明文 
		}
		
		int num=kmp(str,str1);
		if(2*num==lenn)
		{
			cout<<str<<endl;
		}
		else
		{
			cout<<str;
			for(int i=num;i<lenn-num;i++)
			{
				cout<<str1[i];
			}
			cout<<endl;
		}
	}
	return 0;	   
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章