po2406Power Strings

Power Strings
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 49274   Accepted: 20527

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.


題目意思:一道求週期的題目,讓你找出一個前綴在串中週期出現的次數最多,例如abababab就是4

解題思路:一開始用kmp去做沒想太多直接一個一個找,最後超時了。然後仔細想了下,發現直接用kmp的next數組做就行。


#include<iostream>
#include<cstring>

using namespace std;

int const maxn=1000005;

char str[maxn];
int next1[maxn];

int len;

void sign()
{
	int i=-1,j=0;
	next1[0]=-1;
	int len=strlen(str);
	while(j<len)
	{
		if(i==-1||str[i]==str[j])
		{
			i++;
			j++;
			next1[j]=i;
		}
		else
		{
			i=next1[i];
		}
	}
}



int main()
{
	int num;
	while(cin>>str&&str[0]!='.')
	{
		memset(next1,0,sizeof(next1));
		len=strlen(str);
	    sign();
	    int i=len-next1[len];
	    if(len%i==0)    //一定要判斷整除,只有能整除的纔有週期 
	    {
	    	num=len/i;
		}
		else
		   num=1;
		cout<<num<<endl;
		
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章