Folding a Ribbon(思维)

问题 F: Folding a Ribbon

时间限制: 1 Sec  内存限制: 128 MB
提交: 11  解决: 9
[提交] [状态] [讨论版] [命题人:admin]

题目描述

Think of repetitively folding a very long and thin ribbon. First, the ribbon is spread out from left to right, then it is creased at its center, and one half of the ribbon is laid over the other. You can either fold it from the left to the right, picking up the left end of the ribbon and laying it over the right end, or from the right to the left, doing the same in the reverse direction. To fold the already folded ribbon, the whole layers of the ribbon are treated as one thicker ribbon, again from the left to the right or the reverse. 
After folding the ribbon a number of times, one of the layers of the ribbon is marked, and then the ribbon is completely unfolded restoring the original state. Many creases remain on the unfolded ribbon, and one certain part of the ribbon between two creases or a ribbon end should be found marked. Knowing which layer is marked and the position of the marked part when the ribbon is spread out, can you tell all the directions of the repeated folding, from the left or from the right? 
The figure below depicts the case of the first dataset of the sample input. 

 

输入

The input consists of at most 100 datasets, each being a line containing three integers. 
n i j
The three integers mean the following: The ribbon is folded n times in a certain order; then, the i-th layer of the folded ribbon, counted from the top, is marked; when the ribbon is unfolded completely restoring the original state, the marked part is the j-th part of the ribbon separated by creases, counted from the left. Both i and j are one-based, that is, the topmost layer is the layer 1 and the leftmost part is numbered 1. These integers satisfy 1 ≤ n ≤ 60, 1 ≤ i ≤ 2n, and 1 ≤ j ≤ 2n. 
The end of the input is indicated by a line with three zeros. 

 

 

输出

For each dataset, output one of the possible folding sequences that bring about the result specified in the dataset. 
The folding sequence should be given in one line consisting of n characters, each being either L or R. L means a folding from the left to the right, and R means from the right to the left. The folding operations are to be carried out in the order specified in the sequence. 

 

 

样例输入

3 3 2
12 578 2214
59 471605241352156968 431565444592236940
0 0 0

 

样例输出

LRR
RLLLRRRLRRLL
LRRRLRRLLRRRRLLLLRLLRRRLRRLLRLLLLLLRLRLLRLRLLLRLRLLRLLRRRLL

题目大意是说给你一张纸,每次向左或者向右折,告诉你折了N次以后从上向下数第i个在折叠前是第j部分,求从第一次到第N次是分别是向左折还是向右折。

 

我的解法是先从后往前求每次折叠以后第j个在从下向上数第cnt[i]个位置(如果cnt[i] < 厚度的一半,则cnt[i-1]=cnt[i];否则cnt[i-1]  = 厚度-cnt[i]+1,即是从下半部分折叠上来的),求出所有的cnt[i]之后,再从前往后遍历。因为如果是把改点折叠到另一半上面,则它的位置会上浮,否则保持不变,与此同时,我们更新这个点是当前从左往右数第几个,即可知道当前点是在左半边还是右半边,再根据cnt[i]的变化即可得到折叠方向。

 

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn = 100005;
ll poww[64];
ll cntt[100];
int cnt = 0;
int main()
{
//    freopen("in.txt", "r", stdin);
    ll n,m,k;
    poww[0] = 1;
    for (int i = 1; i <= 62; i++)
        poww[i] = poww[i - 1] << 1;
    while (~scanf("%lld%lld%lld",&n,&m,&k))
    {
        if (!n && !m && !k)
            break;
        m = cntt[n] = poww[n] - m + 1;
        for (cnt = n; cnt > 1; cnt--)
        {
            if (m > poww[cnt - 1])
                m = poww[cnt] - m + 1;
            cntt[cnt - 1] = m;
        }
        for (int i = 1; i <= n; i++)
        {
            if (k <= poww[n - i])
            {
                if (cntt[i] <= poww[i - 1])
                    printf("R");
                else
                {
                    printf("L");
                    k = poww[n - i] - k + 1;
                }
            }
            else
            {
                if (cntt[i] > poww[i - 1])
                {
                    printf("R");
                    k = poww[n - i + 1] - k + 1;
                }
                else
                {
                    printf("L");
                    k -= poww[n - i];
                }
            }
        }
        puts("");
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章