DM***的第三階段EIGRP

DM***的第三階段EIGRP
R1#sho run int tun 0
Building configuration...
Current configuration : 378 bytes
interface Tunnel0
ip address 10.1.1.1 255.255.255.0
no ip redirects
ip nhrp authentication 123
ip nhrp map multicast dynamic
ip nhrp network-id 100
ip nhrp redirect
ip summary-address eigrp 1 2.0.0.0 255.0.0.0 //EIGRP必須下發一條默認或彙總路由使spoke發出進入tunnel的觸發流量, 一般下發的是默認路由。
ip summary-address eigrp 1 3.0.0.0 255.0.0.0
tunnel source Ethernet0/0
tunnel mode gre multipoint
tunnel key 100
End

R1#sho ip route
Gateway of last resort is 100.1.18.8 to network 0.0.0.0
S* 0.0.0.0/0 [1/0] via 100.1.18.8
1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 1.1.1.0/24 is directly connected, Loopback0
L 1.1.1.1/32 is directly connected, Loopback0
2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 2.0.0.0/8 is a summary, 00:16:29, Null0
D 2.2.2.0/24 [90/27008000] via 10.1.1.2, 00:16:38, Tunnel0
3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 3.0.0.0/8 is a summary, 00:16:38, Null0
D 3.3.3.0/24 [90/27008000] via 10.1.1.3, 00:22:29, Tunnel0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, Tunnel0
L 10.1.1.1/32 is directly connected, Tunnel0
100.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 100.1.18.0/24 is directly connected, Ethernet0/0
L 100.1.18.1/32 is directly connected, Ethernet0/0

R2#sho run int tun 0
Building configuration...
Current configuration : 344 bytes
interface Tunnel0
ip address 10.1.1.2 255.255.255.0
no ip redirects
ip nhrp authentication 123
ip nhrp map 10.1.1.1 100.1.18.1
ip nhrp map multicast 100.1.18.1
ip nhrp network-id 100
ip nhrp nhs 10.1.1.1
ip nhrp shortcut
tunnel source Ethernet0/0
tunnel mode gre multipoint
tunnel key 100
End

R2#sho ip route
Gateway of last resort is 100.2.28.8 to network 0.0.0.0
S* 0.0.0.0/0 [1/0] via 100.2.28.8
1.0.0.0/24 is subnetted, 1 subnets
D 1.1.1.0 [90/27008000] via 10.1.1.1, 00:23:59, Tunnel0
2.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
D 2.0.0.0/8 [90/28288000] via 10.1.1.1, 00:17:40, Tunnel0
C 2.2.2.0/24 is directly connected, Loopback0
L 2.2.2.2/32 is directly connected, Loopback0
3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 3.0.0.0/8 [90/28288000] via 10.1.1.1, 00:17:49, Tunnel0
H 3.3.3.0/24 [250/1] via 10.1.1.3, 00:14:52, Tunnel0 //eigrp環境中,nhrp直接生成路由加載在路由表中
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, Tunnel0
L 10.1.1.2/32 is directly connected, Tunnel0
100.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 100.2.28.0/24 is directly connected, Ethernet0/0
L 100.2.28.2/32 is directly connected, Ethernet0/0

R3#sho run int tun 0
Building configuration...
Current configuration : 344 bytes
interface Tunnel0
ip address 10.1.1.3 255.255.255.0
no ip redirects
ip nhrp authentication 123
ip nhrp map 10.1.1.1 100.1.18.1
ip nhrp map multicast 100.1.18.1
ip nhrp network-id 100
ip nhrp nhs 10.1.1.1
ip nhrp shortcut
tunnel source Ethernet0/0
tunnel mode gre multipoint
tunnel key 100
End

R3#sho ip route
Gateway of last resort is 100.3.38.8 to network 0.0.0.0
S* 0.0.0.0/0 [1/0] via 100.3.38.8
1.0.0.0/24 is subnetted, 1 subnets
D 1.1.1.0 [90/27008000] via 10.1.1.1, 00:24:59, Tunnel0
2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 2.0.0.0/8 [90/28288000] via 10.1.1.1, 00:18:59, Tunnel0
H 2.2.2.0/24 [250/1] via 10.1.1.2, 00:16:11, Tunnel0
3.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
D 3.0.0.0/8 [90/28288000] via 10.1.1.1, 00:19:08, Tunnel0
C 3.3.3.0/24 is directly connected, Loopback0
L 3.3.3.3/32 is directly connected, Loopback0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, Tunnel0
L 10.1.1.3/32 is directly connected, Tunnel0
100.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 100.3.38.0/24 is directly connected, Ethernet0/0
L 100.3.38.3/32 is directly connected, Ethernet0/0

R3# traceroute 2.2.2.2 source 3.3.3.3 numeric
Type escape sequence to abort.
Tracing the route to 2.2.2.2
VRF info: (vrf in name/id, vrf out name/id)
1 10.1.1.2 2 msec * 1 msec

注意:
1、第三階段的DM***,在eigrp環境下,不能再用修改下一跳,以及水平分割,否則就成了第二階段。
2、由於eigrp受到水平分割的限制,所以server需要在隧道口下放默認路由或彙總,一般下發默認,使spoke能有觸發流量。
3、在server上下放默認或彙總,是爲了讓更精確的路由加載到路由表中。
4、由於R2、R3已經配置了靜態默認,本實驗使用的是下放彙總,但server要想下放默認,可以使用VRF.

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章