路由器配置大全



 交換機口令設置:

switch>enable                                       ;進入特權模式

switch#config terminal                              ;進入全局配置模式

switch(config)#hostname <hostname>                  ;設置交換機的主機名

switch(config)#enable secret xxx                    ;設置特權加密口令爲 xxx

switch(config)#enable password xxx                  ;設置特權非密口令爲 xxx

switch(config)#line console 0                       ;進控制檯口(Rs232)初始化

switch(config-line)#line vty 0 4                    ;進入虛擬終端virtual tty

switch(config-line)#login                           ;允許登錄

switch(config-line)#password xx                     ;設置登錄口令xx

switch#exit                                         ;返回命令

 

交換機VLAN設置:

switch#vlan database                                ;進入VLAN設置

switch(vlan)#vlan 2                                 ;建VLAN 2

switch(vlan)#no vlan 2                              ;刪vlan 2

switch(config)#int f0/1                             ;進入端口1

switch(config-if)#switchport access vlan 2          ;當前端口1加入VLAN 2

switch(config-if)#switchport mode trunk             ;設置爲幹線

switch(config-if)#switchport trunk allowed vlan1,2;設置允許的vlan

switch(config-if)#switchport trunk encapdot1q      ;設置vlan中繼

switch(config)#vtp domain <name>                    ;設置發vtp域名

switch(config)#vtp password <word>

switch(config)#vtp mode server

switch(config)#vtp mode client

 交換機設置IP地址:

switch(config)#interface vlan 1                     ;進入vlan 1

switch(config-if)#ip address <IP><mask>            ;添加遠程登錄IP

switch(config)#ip default-gateway <IP>              ;添加默認網關

switch#dir flash:                                   ;查看內存

 交換機顯示命令:

switch#write                                        ;寫入保存

switch#show vtp

switch#show run                                     ;查看當前配置信息

switch#show vlan                                    ;看VLAN

switch#show interface                               ;顯示所有端口信息

switch#show int f0/0                                ;顯示端口0的信息

 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

路由器顯示命令:

router#show run                                     ;顯示接口

router#show interface                               ;顯示接口

router#show ip route                                ;顯示路由

router#show cdp nei                                 ;看鄰居

router#reload                                     ;重新起動

 

設置口令:

router>enable                                       ;進入特權模式

router#config terminal                              ;進入全局配置模式

router(config)#hostname <hostname>                  ;設置交換機的主機名

router(config)#enable secret xxx                    ;設置特權加密口令爲 xxx

router(config)#enable password xxx                  ;設置特權非密口令爲 xxx

router(config)#line console 0                       ;進控制檯口(Rs232)初始化

router(config-line)#line vty 0 4                    ;進入虛擬終端virtual tty

router(config-line)#login                           ;允許登錄

router(config-line)#password xx                     ;設置登錄口令xx

router(config)# (Ctrl+z)                            ;返回特權模式

router#exit                                         ;返回命令

 配置IP地址:

router(config)#int s0/0                             ;進行串Serail接口

router(config-if)#no shutdown                       ;起動接口

router(config-if)#clock rate 64000                  ;設置時鐘

router(config-if)#ip address 10.1.1.1255.255.0.0   ;設置IP地址和子網掩碼

router(config-if)#ip add 10.1.1.2 255.255.0.0second

router(config-if)#int f0/0.1                        ;進入子接口

router(config-subif.1)#ip address<ip><netmask>    

router(config-subif.1)#encapsulation dot1q<n>       

router(config)#config-register 0x2142               ;跳過配置文件

router(config)#config-register 0x2102               ;正常使用配置文件

router#reload                                       ;重新引導

 複製操作:

router#copy running-config startup-config           ;存配置

router#copy running-config tftp                     ;上載

router#copy startup-config tftp

router#copy tftp flash:                             ;特權模式下升級IOS

router#copy tftp startup-config             ;下載配置文件到nvram

 

ROM狀態:

Ctrl+Break                                          ;進入ROM監控狀態

rommon>confreg 0x2142                               ;跳過配置,26 36 45xx

rommon>confreg 0x2102                               ;使用配置,恢復工作狀態

rommon>reset                                   ;重新引導,等效於重開機

rommon>copy xmodem:<sname>flash:<dname>            ;從console升級IOS

 rommon>IP_ADDRESS=10.65.1.2                         ;設置路由器IP

rommon>IP_SUBNET_MASK=255.255.0.0                   ;設置路由器掩碼

rommon>TFTP_SERVER=10.65.1.1                        ;指定TFTP服務器IP

rommon>TFTP_FILE=c2600.bin                          ;所要下載的文件

rommon>tftpdnld                                     ;ROM監控狀態下升級IOS

rommon>dir flash:                                   ;查看閃存中的內容

rommon>boot                                         ;引導IOS

 

靜態路由:

ip route <ip-address> <subnet-mask><gateway>   例:

router(config)#ip route 10.1.0.0 255.255.0.010.2.1.1

router(config)#ip route 0.0.0.0 0.0.0.01.1.1.2   

 

動態路由:

router(config)#ip routing                           ;啓動路由

router(config)#router rip                           ;啓動RIP路由協議。

router(config-router)#network <netid>               ;配置範圍,有的支持all。

router(config-router)#negihbor<ip-address>         ;點對點 幀中繼用。

 

幀中繼命令:

router(config)# frame-relay switching               ;使能幀中繼交換

router(config-s0)# encapsulation frame-relay        ;使能幀中繼

router(config-s0)# frame-relay intf-type DCE        ;DCE端(需要配虛電路)

router(config-s0)# frame-relay local-dlci 20        ;配置虛電路號

 

基本訪問控制列表:

router(config)#access-list <number>permit|deny <source ip> <wild|any>

router(config)#interface <interface>                ;default: deny any

router(config-if)#ip access-group <number>in|out   ;default: out

 

例:

RB(config)#access-list 4 permit 10.8.1.1

RB(config)#access-list 4 deny 10.8.1.0 0.0.0.255

RB(config)#access-list 4 permit 10.8.0.00.0.255.255

RB(config)#access-list 4 deny 10.0.0.00.255.255.255

RB(config)#access-list 4 permit any             

RB(config)#int f0/0

RB(config-if)#ip access-group 4 in

 

 

擴展訪問控制列表:

access-list <number> permit|deny icmp<SourceIP wild> <destinationIP

wild>[type]

access-list <number> permit|deny tcp<SourceIP wild> <destinationIP

wild>[port]

例1:

router(config)#access-list 101 deny icmp any10.64.0.2 0.0.0.0 echo

router(config)#access-list 101 permit ip any any

router(config)#int s0/0

router(config-if)#ip access-group 101 in

例2:

router(config)#access-list 102 deny tcp any10.65.0.2 0.0.0.0 eq 80

router(config)#access-list 102 permit ip any any

router(config)#interface s0/1

router(config-if)#ip access-group 102 out

 

router(config)#no access-list 102

router(config-if)#no ip access-group 101 in

 

在路由器上設置 SNMP Community Strings

  router(config) # snmp-server community read-community-string ro

 

 router(config) # snmp-server community write-community-string rw

 

在交換機上設置 SNMP Community Strings

switch(config) # snmp-server community    read-community-string ro

 

switch(config) # snmp-server communitywrite-community-string rw

 

 

 

在路由器上配置日誌信息(Syslog Message Logging)

 

router(config) # logging on

 

router(config) # logging server-ip-address

router(config) # logging trap severity-level

路由器恢復出廠設置

erase start-config

或write erase

或erase NVROM

 


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章