HDU 2602 Bone Collector

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input
The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output
One integer per line representing the maximum of the total value (this number will be less than 2^31).

Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output
14

#include<stdio.h>
#include<string>
#include<string.h>
#include<iostream>
#include<queue>
#include<vector>
#include<list>
#include<algorithm>
#include<math.h>
using namespace std;
#define INF 1005
int va[INF],vo[INF],dp[INF];
int main()
{
 int t,n,v;
 cin>>t;
 while(t--)
 {
  memset(va,0,sizeof(va));//一定要初始化
  memset(vo,0,sizeof(vo));//同上
  memset(dp,0,sizeof(dp));//同上
  cin>>n>>v;
  for(int i=0;i<n;i++)
  {
   cin>>va[i];
  }
  for(int i=0;i<n;i++)
  {
   cin>>vo[i];
  }
  for(int i=0;i<n;i++)
  {
   for(int j=v;j>=0;j--)
   {
    if(j>=vo[i])
     dp[j]=max(dp[j],dp[j-vo[i]]+va[i]);
   }
  }
  cout<<dp[v]<<endl;
 }
 //system("puase");
return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章