【題解】POJ 1852 Ants

目錄

 

題目描述

題意分析

AC代碼


題目描述

 

Time limit                                         Memory limit

1000 ms                                             30000 kB

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

題意分析

題意:   長爲 Lcm 的竹竿上有N只不明方向的小螞蟻。其以1cm/s的速度爬行,若兩隻螞蟻遭遇。

              則調轉,問全部螞蟻掉落竹竿的  最短時間 和 最長時間 分別是多少?

 

              關於最短時間,我們僅需要比較 每隻螞蟻到竹竿兩端的距離的最小值,取所有螞蟻的最大值即可

              關於最長時間,則爲兩端的距離的最大值,取所有螞蟻的最大值。

              這是由於兩隻螞蟻相遇,我們可以抽象的看爲數軸上的兩點對穿而過。那麼我們取每隻螞蟻最符合題意的狀態

              便可得到此結果。

 

AC代碼

#include <cstdio>
#include <iostream>
#include <algorithm>
#define INF 0x3f3f3f3f
using namespace std;

int main()
{
    int t,L,n;
    cin>>t;
    while(t--)
    {
        int maxone = 0,minone = 0;
        int p;
        scanf("%d%d",&L,&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&p);
            minone = max( minone , min(p,L-p) );
            maxone = max( maxone , max(p,L-p) );
        }
        printf("%d %d\n",minone,maxone);
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章