Monthly Expense(二分)

Monthly Expense

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input
Line 1: Two space-separated integers: N and M
Lines 2… N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.
Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint
If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

題意:

給定一個序列n個數,分成m段,要求所有分的方案中,最大值最小

分析:

二分這個最大值,首先我們找到左邊界右邊界,因爲是每種分法的最大值,所以最小是n個數中的最大的那個數單獨作爲一段,最大就是n個數求和作爲一段,這樣找的了左右邊界,二分找最大值,按照這個最大值看能分成多少段和m作比較,如果小於m說明這個最大值過大使得段數小,否則說明最大值小。

code:

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int main(){
    int n,m;
    while(~scanf("%d%d",&n,&m)){
        int a[100010];
        int sum = 0;
        int maxa = 0;
        for(int i = 0; i < n; i++){
            scanf("%d",&a[i]);
            maxa = max(maxa,a[i]);
            sum += a[i];
        }
        int l = maxa,r = sum;
        while(l < r){
            int mid = l + r >> 1;
            int cnt = 0,s = 0;
            for(int i = 0; i < n; i++){
                s += a[i];
                if(s > mid){
                    s = a[i];
                    cnt++;
                }
            }
            if(cnt < m) r = mid;//太大,所以分的區間小於m
            else l = mid + 1;//太小,所以分的區間大於m
        }
        printf("%d\n",l);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章