HDU-4709 Herding

Little John is herding his father's cattles. As a lazy boy, he cannot tolerate chasing the cattles all the time to avoid unnecessary omission. Luckily, he notice that there were N trees in the meadow numbered from 1 to N, and calculated their cartesian coordinates (Xi, Yi). To herding his cattles safely, the easiest way is to connect some of the trees (with different numbers, of course) with fences, and the close region they formed would be herding area. Little John wants the area of this region to be as small as possible, and it could not be zero, of course.

Input

The first line contains the number of test cases T( T<=25 ). Following lines are the scenarios of each test case. 
The first line of each test case contains one integer N( 1<=N<=100 ). The following N lines describe the coordinates of the trees. Each of these lines will contain two float numbers Xi and Yi( -1000<=Xi, Yi<=1000 ) representing the coordinates of the corresponding tree. The coordinates of the trees will not coincide with each other.

Output

For each test case, please output one number rounded to 2 digits after the decimal point representing the area of the smallest region. Or output "Impossible"(without quotations), if it do not exists such a region.

Sample Input

1
4
-1.00 0.00
0.00 -3.00
2.00 0.00
2.00 2.00

Sample Output

2.00

題目意思:

       給你n個座標,要你求出用由這些點構成的最小的面積(點可以不全用上)

解題思路:

       想要得到面積最小的圖形,明顯只可能是三角形,而且本題數據範圍小,直接暴力循環求解即可。需要注意的是這題需要用叉乘來求三角形面積。我們知道\underset{a}{\rightarrow}\times\underset{b}{\rightarrow}的幾何意義是由向量a和向量b組成的平行四邊形的面積,因此,我們可以通過\underset{a}{\rightarrow}\times\underset{b}{\rightarrow}/ 2求出一個三角形的面積

#include<iostream>
#include<cmath>
#include<cstdio>

using namespace std;

const double Inf = 1e9;

struct Point{
    double x, y;
};

double getArea(Point a, Point b, Point c) {
    return fabs((a.x - b.x) * (a.y - c.y) - (a.x - c.x) * (a.y - b.y)) / 2;
}

int main() {
    int t, n;
    double minArea, tmp;
    Point P[110];
    scanf("%d",&t);
    while(t--) {
        minArea = Inf;
        scanf("%d",&n);
        for(int i = 0;i < n;i++) {
            scanf("%lf%lf",&P[i].x,&P[i].y);
        }
        for(int i = 0;i < n;i++) {
            for(int j = i + 1;j < n;j++) {
                for(int k = j + 1;k < n;k++) {
                    tmp = getArea(P[i],P[j],P[k]);
                    if(tmp != 0 && tmp < minArea){
                        minArea = tmp;
                    }
                }
            }
        }
        if(minArea < Inf) {
            printf("%.2f\n",minArea);
        }
        else{
            printf("Impossible\n");
        }
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章