HDU-1260 Tickets(簡單DP)

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible. 
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time. 
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help. 

Input

There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines: 
1) An integer K(1<=K<=2000) representing the total number of people; 
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person; 
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together. 

Output

For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm. 

Sample Input

2
2
20 25
40
1
8

Sample Output

08:00:40 am
08:00:08 am

題意爲:

就是一個人賣票,他8點開始上班,票既可以單賣也可以一次賣兩張,給出K個人的單獨買票時間和K-1個相鄰的兩個人一起買票的時間,問一共花費的最小時間。

對於每個狀態,我們都能通過前一個人單買一張票或者相鄰的兩個人一起買票得到

於是可以得到狀態轉移方程:res[i] = min(res[i-1] + arr1[i],res[i-2] + arr2[i]);

其中res存儲結果,arr1存儲單買所需的時間,arr2存儲相鄰的兩個人一起買票所需的時間

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>

using namespace std;

int main() {
    int t, n, arr1[2001],arr2[2001],res[2000],tmp,h,m,s;
    scanf("%d",&t);
    while(t--) {
        memset(res,0,sizeof(res));
        h = 8;
        scanf("%d",&n);
        for(int i = 1;i <= n;i++){
            scanf("%d",&arr1[i]);
            res[i] = arr1[i];
        }
        for(int i = 2;i <= n;i++) {
            scanf("%d",&arr2[i]);
        }
        for(int i = 2;i <= n;i++) {
            res[i] = min(res[i-1] + arr1[i],res[i-2] + arr2[i]);
        }
        tmp = res[n];
        h += tmp / 3600;
        tmp %= 3600;
        m = tmp / 60;
        tmp %= 60;
        s = tmp;
        if(h >= 12)
            printf("%02d:%02d:%02d pm\n",h,m,s);
        else
            printf("%02d:%02d:%02d am\n",h,m,s);
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章