一條物理線路上劃分信道(3)

可以做備份路由.具體配置如下:
r1#sh run
Building configuration...
Current configuration : 1470 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1
!
enable password cisco
!
ip subnet-zero
ip cef
!
!
no ip domain-lookup
!
call rsvp-sync
!
!
!
!
!        
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface Tunnel0
ip address 198.98.1.1 255.255.255.0
tunnel source 199.99.1.1
tunnel destination 199.99.1.2
!
interface Tunnel1
ip address 198.98.2.1 255.255.255.0
tunnel source 199.99.1.1
tunnel destination 199.99.1.2
!
interface Tunnel2
ip address 198.98.3.1 255.255.255.0
tunnel source 199.99.1.1
tunnel destination 199.99.1.2
!
interface FastEthernet0/0
ip address 199.99.1.1 255.255.255.0
duplex full
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
ip classless
ip route 2.2.2.0 255.255.255.0 198.98.1.2
ip route 2.2.2.0 255.255.255.0 198.98.2.2 2
ip route 2.2.2.0 255.255.255.0 198.98.3.2 3
no ip http server
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
alias exec a sh ip int brief
alias exec b sh ip route
alias exec c sh ip route rip
alias exec d sh run
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
exec-timeout 0 0
logging synchronous
line vty 0 4
exec-timeout 0 0
password cisco
login
!
end

路由表顯示如下:
r1#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
     2.0.0.0/24 is subnetted, 1 subnets
S       2.2.2.0 [1/0] via 198.98.1.2
C    198.98.2.0/24 is directly connected, Tunnel1
C    198.98.3.0/24 is directly connected, Tunnel2
C    199.99.1.0/24 is directly connected, FastEthernet0/0
C    198.98.1.0/24 is directly connected, Tunnel0

當我們把tunnel0 shutdown 以後,看看路由表的結果
r1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
r1(config)#int tunnel 0
r1(config-if)#shutdown
r1(config-if)#^Z
r1#sh ip
00:20:06: %SYS-5-CONFIG_I: Configured from console by console
00:20:06: %LINK-5-CHANGED: Interface Tunnel0, changed state to administratively down
r1#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
     2.0.0.0/24 is subnetted, 1 subnets
S       2.2.2.0 [2/0] via 198.98.2.2
C    198.98.2.0/24 is directly connected, Tunnel1
C    198.98.3.0/24 is directly connected, Tunnel2
C    199.99.1.0/24 is directly connected, FastEthernet0/0

第2個信道立即就啓用了,呵呵~
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章