RIP實現默認路由分發(1)

 

 

配置如下:

r1#show run
Building configuration...

Current configuration : 720 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname r1
!

no ip domain-lookup
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!

interface Serial0/0/0
 ip address 192.168.1.1 255.255.255.0
 clock rate 64000
!
interface Serial0/0/1
 no ip address
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 network 1.0.0.0
 network 192.168.1.0
!
ip classless
!
router rip
 network 1.0.0.0
 network 192.168.1.0
!
ip classless
!
line con 0
 exec-timeout 0 0
line vty 0 4
 login
!
end

R2#show run
Building configuration...

Current configuration : 827 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!

no ip domain-lookup
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!

interface Serial0/0/0
 ip address 192.168.1.2 255.255.255.0
!
interface Serial0/0/1
 ip address 172.16.1.2 255.255.255.0
 clock rate 64000
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 redistribute static
 network 2.0.0.0
 network 172.16.0.0
 network 192.168.1.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 Null0

!
line con 0
 exec-timeout 0 0
 logging synchronous
line vty 0 4
 login
!
!
!
end

R3#show run

.....

!
interface Loopback0
 ip address 3.3.3.3 255.255.255.0
!

!
interface Serial0/0/1
 ip address 172.16.1.3 255.255.255.0
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0/1
!

.......

end

搞定,在每日一個實驗技術圈裏看到一個rip的重分佈的實驗 圈主的方法是ip default-network 實現

看來條條達到通羅馬 在查查資料看看還能不能找到其他的方法可以實現

Keep Moving!!!

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章