Cisco Packet Tracer 之 三層交換機使用路由協議實驗

實驗環境:

Cisco Packet Tracer 之 三層交換機使用路由協議實驗 - ibm.chick - MingKang.Zhou

 

實驗目的:(兩間公司之間的VLAN互通)

1、在B公司裏配置三層交換機,把FA0/1 FA0/2  FA0/3 設置爲TRUNK端口。

2、在B公司的三層交換機,創建VTP,並且創建VLAN20  VLAN30  VLAN40 VLAN100,並設置相應的IP地址。

3、在B公司的三層交換機,創建各VLAN的IP地址池。

4、在B公司的二層交換機,設置VTP CLIENT。

5、在B公司裏,按圖把各個PC加入到相應的VLAN口中,並查看是否可以獲取IP地址。

6、在B公司的三層交換機裏啓用路由功能IP ROUTING,並測試公司內部各網段是否互通。

備註:以上步驟A公司的操作省略。

7、在兩間公司的專線端口上關閉交換功能,並設置相應的IP地址。

8、先測試兩公司之間的VLAN是否可互通。

9、因各VLAN不是直連,所以必須要在各公司的三層交換機添加相應的路由協議。

10、測試兩個網段之間的PC是否可以互通。


實驗步驟:

1、在B公司裏配置三層交換機,把FA0/1 FA0/2  FA0/3 設置爲TRUNK端口。

CoreSWB(config)#int fa0/1

CoreSWB(config-if)#switchport trunk encapsulation dot1q 

CoreSWB(config-if)#switchport mode trunk

CoreSWB(config)#int fa0/2

CoreSWB(config-if)#switchport trunk encapsulation dot1q

CoreSWB(config-if)#switchport mode trunk

CoreSWB(config)#int fa0/3

CoreSWB(config-if)#switchport trunk encapsulation dot1q

CoreSWB(config-if)#switchport mode trunk

2、在B公司的三層交換機,創建VTP,並且創建VLAN20  VLAN30  VLAN40 VLAN100,並設置相應的IP地址。

CoreSWB(vlan)#vtp domain senya

Changing VTP domain name from NULL to senya

CoreSWB(vlan)#vtp server

Device mode already VTP SERVER.

CoreSWB#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

CoreSWB(config)#vlan 20

CoreSWB(config-vlan)#exit

CoreSWB(config)#vlan 30

CoreSWB(config-vlan)#exit

CoreSWB(config)#vlan 40

CoreSWB(config-vlan)#exit

CoreSWB(config)#vlan 100

CoreSWB(config-vlan)#exit

CoreSWB(config)#int vlan20

CoreSWB(config-if)#ip add 192.168.20.1 255.255.255.0

CoreSWB(config-if)#exit

CoreSWB(config)#int vlan30

CoreSWB(config-if)#ip add 192.168.30.1 255.255.255.0

CoreSWB(config-if)#exit

CoreSWB(config)#int vlan40

CoreSWB(config-if)#

%LINK-5-CHANGED: Interface Vlan40, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to up

CoreSWB(config-if)#ip add 192.168.40.1 255.255.255.0

CoreSWB(config-if)#exit

CoreSWB(config-if)#exit

3、在B公司的三層交換機,創建各VLAN的IP地址池。

CoreSWB(config)#ip dhcp pool vlan20

CoreSWB(dhcp-config)#network 192.168.20.0 255.255.255.0

CoreSWB(dhcp-config)#default-router 192.168.20.1 

CoreSWB(dhcp-config)#exit

CoreSWB(config)#ip dhcp pool vlan30

CoreSWB(dhcp-config)#network 192.168.30.0 255.255.255.0

CoreSWB(dhcp-config)#default-router 192.168.30.1 

CoreSWB(dhcp-config)#exit

CoreSWB(config)#ip dhcp pool vlan40

CoreSWB(dhcp-config)#network 192.168.40.0 255.255.255.0

CoreSWB(dhcp-config)#default-router 192.168.40.1 

CoreSWB(dhcp-config)#exit

4、在B公司的二層交換機,設置VTP CLIENT。(只顯示一個交換機的操作步驟)

Switch#vlan database 

% Warning: It is recommended to configure VLAN from config mode,

  as VLAN database mode is being deprecated. Please consult user

  documentation for configuring VTP/VLAN in config mode.

Switch(vlan)#vtp domain senya

Domain name already set to senya.

Switch(vlan)#vtp client

Setting device to VTP CLIENT mode.

Switch(vlan)#exit

APPLY completed.

Switch#show vlan

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/5

                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9

                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13

                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17

                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21

                                                Fa0/22, Fa0/23, Fa0/24

20   VLAN0020                         active    

30   VLAN0030                         active    

40   VLAN0040                         active    

100  VLAN0100                         active    

1002 fddi-default                     act/unsup 

1003 token-ring-default               act/unsup 

1004 fddinet-default                  act/unsup 

1005 trnet-default                    act/unsup 

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1    enet  100001     1500  -      -      -        -    -        0      0

20   enet  100020     1500  -      -      -        -    -        0      0

5、在B公司裏,按圖把各個PC加入到相應的VLAN口中,並查看是否可以獲取IP地址。(其它交換機操作省略)

Switch#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#int fa0/2

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 20

Cisco Packet Tracer 之 三層交換機使用路由協議實驗 - ibm.chick - MingKang.Zhou

 

Cisco Packet Tracer 之 三層交換機使用路由協議實驗 - ibm.chick - MingKang.Zhou

 

Cisco Packet Tracer 之 三層交換機使用路由協議實驗 - ibm.chick - MingKang.Zhou

 

6、在B公司的三層交換機裏啓用路由功能IP ROUTING,並測試公司內部各網段是否互通。

在沒有IP ROUTING的情況下如下:

Cisco Packet Tracer 之 三層交換機使用路由協議實驗 - ibm.chick - MingKang.Zhou

在三層交換機啓用IP ROUTING後,如下:

Cisco Packet Tracer 之 三層交換機使用路由協議實驗 - ibm.chick - MingKang.Zhou

7、在兩間公司的專線端口上關閉交換功能,並設置相應的IP地址和測試是否能PING通。

A公司:

CoreSW(config)#int fa0/4

CoreSW(config-if)#no switchport

CoreSW(config-if)#ip add 192.168.100.1 255.255.255.0

B公司:

CoreSWB(config)#int fa0/5

CoreSWB(config-if)#no switchport

CoreSWB(config-if)#ip add 192.168.100.2 255.255.255.0

兩公司之間互通:

CoreSW#PING 192.168.100.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.100.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms

 

8、先測試兩公司之間的VLAN是否可互通。

Cisco Packet Tracer 之 三層交換機使用路由協議實驗 - ibm.chick - MingKang.Zhou

CoreSW#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.2.0/24 is directly connected, Vlan2

C    192.168.3.0/24 is directly connected, Vlan3

C    192.168.4.0/24 is directly connected, Vlan4

C    192.168.100.0/24 is directly connected, FastEthernet0/4

9、因各VLAN不是直連,所以必須要在各公司的三層交換機添加相應的路由協議。

 A公司添加B公司的VLAN網段信息如下:

CoreSW#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

CoreSW(config)#router rip

CoreSW(config-router)#ver 2

CoreSW(config-router)#no au

CoreSW(config-router)#net 192.168.2.0

CoreSW(config-router)#net 192.168.3.0

CoreSW(config-router)#net 192.168.4.0

CoreSW(config-router)#net 192.168.100.0

 

B公司添加A公司的VLAN網段信息如下:

CoreSWB#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

CoreSWB(config)#router rip

CoreSWB(config-router)#ver 2

CoreSWB(config-router)#no au

CoreSWB(config-router)#net 192.168.20.0

CoreSWB(config-router)#net 192.168.30.0

CoreSWB(config-router)#net 192.168.40.0

CoreSWB(config-router)#net 192.168.100.0

RIP協議是把自己本網段的VLAN宣告到別的交換機上。

A公司三層交換機的路由表情況:

CoreSW#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.2.0/24 is directly connected, Vlan2

C    192.168.3.0/24 is directly connected, Vlan3

C    192.168.4.0/24 is directly connected, Vlan4

R    192.168.20.0/24 [120/1] via 192.168.100.2, 00:00:25, FastEthernet0/4

R    192.168.30.0/24 [120/1] via 192.168.100.2, 00:00:25, FastEthernet0/4

R    192.168.40.0/24 [120/1] via 192.168.100.2, 00:00:25, FastEthernet0/4

C    192.168.100.0/24 is directly connected, FastEthernet0/4

B公司的路由表情況如下:

CoreSWB#

CoreSWB#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

Gateway of last resort is not set

R    192.168.2.0/24 [120/1] via 192.168.100.1, 00:00:10, FastEthernet0/4

R    192.168.3.0/24 [120/1] via 192.168.100.1, 00:00:10, FastEthernet0/4

R    192.168.4.0/24 [120/1] via 192.168.100.1, 00:00:10, FastEthernet0/4

C    192.168.20.0/24 is directly connected, Vlan20

C    192.168.30.0/24 is directly connected, Vlan30

C    192.168.40.0/24 is directly connected, Vlan40

C    192.168.100.0/24 is directly connected, FastEthernet0/4

10、測試兩個網段之間的PC是否可以互通。 

Cisco Packet Tracer 之 三層交換機使用路由協議實驗 - ibm.chick - MingKang.Zhou


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章