PAT甲級A1152 Google Recruitment (20 分)

In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google's hiring process by visiting this website.

prime.jpg

The natural constant e is a well known transcendental number(超越數). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921... where the 10 digits in bold are the answer to Google's question.

Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

Input Specification:

Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

Output Specification:

For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

Sample Input 1:

20 5
23654987725541023819

Sample Output 1:

49877

Sample Input 2:

10 3
2468024680

Sample Output 2:

404

題意:給出一個長度爲l的數s(字符串形式讀入),讓你找出其中第一個長度爲k位的質數並輸出這個質數,如果不存在輸出:404。

思路:首先寫一個判斷質數的函數judge,接下來從第一位開始遍歷這個給定的數 s,並每次截取從當前位置開始長度爲k的子串,送入函數judge判斷,是否是質數,如果是就輸出質數,否則直到遍歷結束,如果都沒有答案,則輸出:404.

參考代碼:

#include<cstdio>
#include<cstring>
#include<string>
#include<iostream>
#include<cmath>
using namespace std;
bool judge(string s){
	int n=stoi(s),sqrtN=sqrt(1.0*n);
	if(n<2) return false;
	for(int i=2;i<=sqrtN;i++){
		if(n%i==0) return false;
	}
	return true;
}
int main()
{
	int l,k,flag=0;
	string s,ans;
	cin>>l>>k>>s;
	for(int i=0;i<=l-k&&!flag;i++){
		ans=s.substr(i,k);
		if(judge(ans)) 
			flag=1;
	}
	if(flag) cout<<ans<<endl;
	else cout<<"404\n";
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章