PAT甲級A1139 First Contact (30 分)

Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years. When a boy A had a crush on a girl B, he would usually not contact her directly in the first place. Instead, he might ask another boy C, one of his close friends, to ask another girl D, who was a friend of both B and C, to send a message to B -- quite a long shot, isn't it? Girls would do analogously.

Here given a network of friendship relations, you are supposed to help a boy or a girl to list all their friends who can possibly help them making the first contact.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (1 < N ≤ 300) and M, being the total number of people and the number of friendship relations, respectively. Then M lines follow, each gives a pair of friends. Here a person is represented by a 4-digit ID. To tell their genders, we use a negative sign to represent girls.

After the relations, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each gives a pair of lovers, separated by a space. It is assumed that the first one is having a crush on the second one.

Output Specification:

For each query, first print in a line the number of different pairs of friends they can find to help them, then in each line print the IDs of a pair of friends.

If the lovers A and B are of opposite genders, you must first print the friend of A who is of the same gender of A, then the friend of B, who is of the same gender of B. If they are of the same gender, then both friends must be in the same gender as theirs. It is guaranteed that each person has only one gender.

The friends must be printed in non-decreasing order of the first IDs, and for the same first ones, in increasing order of the seconds ones.

Sample Input:

10 18
-2001 1001
-2002 -2001
1004 1001
-2004 -2001
-2003 1005
1005 -2001
1001 -2003
1002 1001
1002 -2004
-2004 1001
1003 -2002
-2003 1003
1004 -2002
-2001 -2003
1001 1003
1003 -2001
1002 -2001
-2002 -2003
5
1001 -2001
-2003 1001
1005 -2001
-2002 -2004
1111 -2003

Sample Output:

4
1002 2004
1003 2002
1003 2003
1004 2002
4
2001 1002
2001 1003
2002 1003
2002 1004
0
1
2003 2001
0

題意:給出n個人,m對朋友關係,如果A和B一見鍾情,則需要找出A的同性朋友C,B的同性朋友D,若C和D是朋友,則滿足給A和B傳遞消息的條件,給出q對一見鍾情的A,B,讓你輸出所有符合以上條件的朋友對,注意按朋友id升序排列。

思路:首先做鄰接表,表示每個人的朋友,用數組gender[]保存每個人的性別,接下來,對於給定的A和B,逐個遍歷A的朋友C和B的朋友D,如果C與A同性,D與B同性並且C和D是朋友則保存下來,最後輸出所有滿足條件的朋友對 ,爲了保證按朋友id升序輸出,可以對A,B的朋友按id升序排序。

注意:①輸入的數據有-0000,如果按整形讀入,則會誤判性別,因此需要按字符串讀入數據。

           ②注意如果A和B是朋友且爲同性,則注意A的朋友會有B,B的朋友裏會有A,要保證C不是A,D不是B,否則會輸出錯誤答案。

參考代碼:

#include<cstdio>
#include<vector>
#include<string>
#include<cmath>
#include<iostream>
#include<algorithm>
using namespace std;
vector<int> adj[10000];
int n,m,q,gender[10000];	//女生爲0,男生爲1
struct node{
	int fu,fv;
	node(int u,int v):fu(u),fv(v){}
};
bool judge(int u,int v){	//判斷給定的兩個人是否是朋友關係
	for(int i=0;i<adj[u].size();i++){
		if(adj[u][i]==v)
			return true;
	}
	return false;
}
int main()
{
	int u,v;
	string a,b;
	scanf("%d%d",&n,&m);
	for(int i=0;i<m;i++){
		cin>>a>>b;
		u=abs(stoi(a));
		v=abs(stoi(b));
		if(a.size()==5) gender[u]=1;
		if(b.size()==5) gender[v]=1;
		adj[u].push_back(v);
		adj[v].push_back(u);
	}
	scanf("%d",&q);
	for(int k=0;k<q;k++){
		scanf("%d%d",&u,&v);
		u=abs(u);v=abs(v);
		sort(adj[u].begin(),adj[u].end());
		sort(adj[v].begin(),adj[v].end());
		vector<node> ans;
		for(int i=0;i<adj[u].size();i++){	//遍歷u和v的每一對朋友看看是否是朋友關係
			for(int j=0;j<adj[v].size();j++){
				int fu=adj[u][i],fv=adj[v][j];
				if(gender[u]==gender[fu]&&gender[v]==gender[fv]&&fu!=v&&fv!=u&&judge(fu,fv))	
					ans.push_back(node(fu,fv));
			}
		}
		printf("%d\n",ans.size());
		for(int i=0;i<ans.size();i++)
			printf("%04d %04d\n",ans[i].fu,ans[i].fv);
	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章