POJ - 2096 Collecting Bugs

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program. 
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category. 
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version. 
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem. 
Find an average time (in days of Ivan's work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000

 

題目長的要死,大概就是有s個子系統,有n種bug。某人每天隨機從一個子系統裏找一個bug,問找完所有bug的期望。

這應該是我第一次認真做概率dp。總的來說,求概率的需要從前往後推,求期望的需要從後往前推:顯而易見,第一次的概率是已知的,最後一次的期望也是已知的,根據題意爲0或者是啥的。

顯然,dp[i][j]有四種轉移方式:dp[i][j](同系統同bug),dp[i+1][j+1](新系統新bug),dp[i+1][j](同系統新bug),dp[i][j+1](新系統同bug),他們的概率分別爲i*j / (n*s),(n-i)*j / (n*s),i*(s-j) / (n*s),(n-i)*(s-j) / (n*s)。

而期望可以分解爲子期望的加權和,這也是遞推求期望的基礎。很容易知道d[n][s]爲0,即找到所有系統的所有bug以後不需要再花天數找bug,以此往前推就行,注意式子要化簡,不然會損失精度。

AC代碼:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

 double dp[1010][1010];

int main()
{
    int n,s,ns;
    cin>>n>>s;
    ns=n*s;
    dp[n][s]=0.0;
    for(int i=n;i>=0;i--)
        for(int j=s;j>=0;j--)
        {
            if(i==n&&j==s)
                continue;
            dp[i][j]=(ns+(n-i)*j*dp[i+1][j]+i*(s-j)*dp[i][j+1]+(n-i)*(s-j)*dp[i+1][j+1])/(ns-i*j);
        }

    printf("%.4lf\n",dp[0][0]);
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章