ZOJ - 3329 One Person Game

There is a very simple and interesting one-person game. You have 3 dice, namely Die1Die2 and Die3Die1 has K1 faces. Die2 has K2 faces. Die3 has K3 faces. All the dice are fair dice, so the probability of rolling each value, 1 to K1K2K3 is exactly 1 / K1, 1 / K2 and 1 / K3. You have a counter, and the game is played as follow:

  1. Set the counter to 0 at first.
  2. Roll the 3 dice simultaneously. If the up-facing number of Die1 is a, the up-facing number of Die2 is b and the up-facing number of Die3 is c, set the counter to 0. Otherwise, add the counter by the total value of the 3 up-facing numbers.
  3. If the counter's number is still not greater than n, go to step 2. Otherwise the game is ended.

Calculate the expectation of the number of times that you cast dice before the end of the game.

 

Input

 

There are multiple test cases. The first line of input is an integer T (0 < T <= 300) indicating the number of test cases. Then T test cases follow. Each test case is a line contains 7 non-negative integers nK1K2K3abc (0 <= n <= 500, 1 < K1K2K3 <= 6, 1 <= a <= K1, 1 <= b <= K2, 1 <= c <= K3).

 

Output

 

For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.

 

Sample Input

 

2
0 2 2 2 1 1 1
0 6 6 6 1 1 1

 

Sample Output

 

1.142857142857143
1.004651162790698

 

這題實在是……太巧妙了 只能說kuangbin牛逼。

https://blog.csdn.net/qingshui23/article/details/77776018這篇文章的公式貼的比較好,實際你會發現網上關於這道題的題解都大同小異,因爲kuangbin實在是牛逼。

稍微補充一點就是,p0其實是三面各爲一個特定值的概率,所以清零的概率也是p0,甩出點數和爲x的概率就是三個骰子有多少種方式組成x再乘個p0

AC代碼:

#include <bits/stdc++.h>

using namespace std;

const int maxn=520;
double A[maxn];
double B[maxn];
double p[maxn];
double p0;
int n,k1,k2,k3,a,b,c;

void getp()
{
    for(int i=1;i<=k1;i++)
        for(int j=1;j<=k2;j++)
            for(int k=1;k<=k3;k++)
    {
        if(i!=a||j!=b||k!=c)
            p[i+j+k]+=p0;
    }
}

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        cin>>n>>k1>>k2>>k3>>a>>b>>c;
        memset(p,0,sizeof(p));
        memset(A,0,sizeof(A));
        memset(B,0,sizeof(B));
        p0=1.0/(k1*k2*k3);
        getp();
        for(int i=n;i>=0;i--)
        {
            for(int j=3;j<=k1+k2+k3;j++)
            {
                A[i]+=p[j]*A[i+j];
                B[i]+=p[j]*B[i+j];
            }
            A[i]+=p0;
            B[i]+=1;
        }
         printf("%.15f\n",B[0]/(1-A[0]));
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章