POJ - 3071 Football

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After nrounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins)  P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)
p21p34p23 + p21p43p24
= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.

The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

給你2^n只足球隊和他們戰勝另外隊伍的概率,讓他們兩兩比賽,勝者再兩兩比賽(大概有個學名?),求勝率最高的隊伍。

這道題很貼心的給了提示,看完提示像我這樣的弟弟大概也能想到dp方法了:dp[i][j]表示第i輪第j只隊伍的勝率,轉移方程爲dp[i][j]=dp[i][j]=dp[i-1][j]*sum,sum爲和其他所有可能比賽的隊伍勝率之和,即\sumdp[i-1][k]*p[j][k]。那麼這道題的主要問題是如何找出所有的k。

注意到所有的比賽都是兩兩進行,隊伍正好有2^n支,我們可以構造成完全二叉樹,所有的隊伍都是葉子節點,父節點的權值爲勝利的隊伍。這樣的話,能和a交戰的隊伍就是父節點和a爲兄弟節點的節點。(給二叉樹學的和我一樣爛的同學的提示,右移操作能找出父節點,異或操作能找出兄弟節點)

AC代碼:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const int maxn=150;
double p[maxn][maxn];
double dp[maxn][maxn];
int main()
{
    int n;
    while(cin>>n&&(n+1))
    {
        int m=(1<<n);
        for(int i=0;i<m;i++)
            for(int j=0;j<m;j++)
                scanf("%lf",&p[i][j]);
        memset(dp,0,sizeof(dp));
        for(int i=0;i<m;i++)
            dp[0][i]=1;
        for(int i=1;i<=n;i++)
            for(int j=0;j<m;j++)
                for(int k=0;k<m;k++)
                    if((j>>(i-1)^1)==(k>>(i-1)))
                        dp[i][j]+=dp[i-1][j]*dp[i-1][k]*p[j][k];

        int ans=0;
        for(int i=0;i<m;i++)
            if(dp[n][i]>dp[n][ans])
                ans=i;
        cout<<ans+1<<endl;
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章