HDU 1016 Uniform Generator GCD

Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

seed(x+1) = [seed(x) + STEP] % MOD

where '%' is the modulus operator. 

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1. 

For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations. 

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1. 

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers. 

 

 

Input

Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).

 

 

Output

For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in column 25. The "Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each output test set, your program should print exactly one blank line.

 

 

Sample Input


 

3 5 15 20 63923 99999

 

 

Sample Output


 

3 5 Good Choice 15 20 Bad Choice 63923 99999 Good Choice

 

給定一個step,一個mod,問能否生成一個{0,mod-1}的序列
s[x]=(s[x-1]%mod+step)%mod.
直接判定gcd(step,mod)==1即可
數論。隨機數生成的數字的第x+1個數字爲:
seed(x+1) = (seed(x)+STEP)%MOD = (seed(x)%MOD + STEP%MOD)%MOD

? ? ? ? ? ? = ... = (seed(0)%MOD + (STEP*x)%MOD)%MOD
如果不能生成全部序列一定存在 0 <= i ,j < MOD 使得生成值相同,即:
seed(i) = (seed(0)%MOD + (STEP*i)%MOD)%MOD
seed(j) =?(seed(0)%MOD + (STEP*j)%MOD)%MOD
由seed(i) = seed(j) 可以得知?(STEP*(j-i))%MOD = 0 且 i ≠ j,即STEP*(j-i)爲MOD的倍數;
又因爲 j-i < MOD 所以gcd( STEP,MOD ) ≠ 1。
(STEP中一定含有MOD的因子,若MOD整除j-i,則STEP含有MOD/(j-i),否則STEP含有MOD)
由此可知,可以生成全部序列的充要條件是?gcd( STEP,MOD ) = 1。

#include<iostream>
#include<string>
#include<algorithm>
#include<stack>
#include<map>
#include<vector>
#include<set>
#include<queue>
using namespace std;
const int maxn = 1e4;
int gcd(int a, int b)
{
	return a%b ? gcd(b, a%b) : b;
}
int main()
{
	//freopen("C://input.txt","r", stdin);
	int step, mod;
	while (scanf("%d%d", &step, &mod) != EOF)
	{
		printf("%10d%10d", step, mod);
		if (gcd(step, mod) == 1)
		{
			printf("    Good Choice\n");
		}
		else
			printf("    Bad Choice\n");
		printf("\n");
	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章