PTA-1009 Product of Polynomials (25 分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

題意:求兩個浮點型多項式的乘積,按指數的降序輸出。

解析:將兩個多項式逐項相乘,注意最後輸出的時候要從指數爲2000開始降序輸出

#include<iostream>
#include<cstring>
#include<string.h>
#include<stdio.h>
#include<algorithm>
using namespace std;
#define maxn 100005
#define eps 1e-6
double a[maxn];
double b[maxn];
double sum[maxn];
int main()
{
   int n,m;
   scanf("%d",&n);
   for(int i = 0; i < n; i ++)
   {
        int x;
        double y;
        cin>>x>>y;
        a[x] += y;
   }
   scanf("%d",&m);
   for(int i = 0; i < m; i ++)
   {
       int x;
       double y;
       cin>>x>>y;
       b[x] += y;
   }
   for(int i = 0; i <= 1000; i ++)
   {
       for(int j = 0; j <= 1000; j ++)
       {
           if(a[i]&&b[j])
           sum[i+j] += a[i]*b[j];
       }
   }
   int counts = 0;
   for(int i = 2000; i >= 0; i --)
   {
       if(sum[i])
            counts ++;
   }
   printf("%d",counts);
   for(int i = 2000; i >= 0; i --)
   {
       if(sum[i])
            printf(" %d %.1f",i,sum[i]);
   }
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章