PTA-1006 Sign In and Sign Out (25 分)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

題意:輸出最早來和最晚走的人的編號

解析:將時間都轉化爲秒的形式,用結構體數組排一下序。

#include<iostream>
#include<cstring>
#include<string.h>
#include<stdio.h>
#include<algorithm>
using namespace std;
#define maxn 100005
struct node
{
    string name;
    int start;
    int ends;
}s[maxn];
int cmp1(struct node x,struct node y)
{
    return x.start < y.start;
}
int cmp2(struct node x,struct node y)
{
    return x.ends > y.ends;
}
int main()
{
    int t;
    scanf("%d",&t);
    for(int i = 0; i < t; i ++)
    {
        string temp;
        cin>>temp;
        s[i].name = temp;
        int a,b,c;
        scanf("%d:%d:%d",&a,&b,&c);
        int k = a*3600+b*60+c;
        s[i].start = k;
        scanf("%d:%d:%d",&a,&b,&c);
        k = a*3600+b*60+c;
        s[i].ends = k;
    }
    sort(s,s+t,cmp1);
    cout<<s[0].name;
    cout<<" ";
    sort(s,s+t,cmp2);
    cout<<s[0].name;
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章