PTA甲級1046 Shortest Distance (20分)

題目原文

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,105]), followed by N integer distances D1 D2 ⋯ D**N, where D**i is the distance between the i-th and the (i+1)-st exits, and D**N is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

代碼如下:

#include<iostream>
using namespace std;
int main(void) {
	int a[100005], N, M, Sum = 0, dis[100005] = {0};
	int Begin, End, Min;
	scanf("%d", &N);
	for (int i = 1; i <=N; i++) {
		scanf("%d", &a[i]);
		Sum += a[i];
		dis[i] = Sum;
	}
	scanf("%d", &M);
	for (int i = 0; i < M; i++) {
		Min = 0;
		scanf("%d%d", &Begin, &End);
		if (Begin > End) {
			int t = Begin;
			Begin = End;
			End = t;
		}
		Min = dis[End - 1] - dis[Begin - 1];
		if ((Sum - Min) < Min) {
			Min = Sum - Min;
		}
		printf("%d\n", Min);
	}

	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章