PTA甲級——1009 Product of Polynomials (25 分)

1009 Product of Polynomials (25 分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

Code:

/*1009
模擬
*/
#include<bits/stdc++.h>
using namespace std;
struct Polynomial{
    int exponent;
    double coefficient;
}A[15],B[15];
int main(){
    int k1,k2,k3=0;
    double C[2005];
    memset(C,0,sizeof(C));
    cin>>k1;
    for(int i=0;i<k1;i++)
        cin>>A[i].exponent>>A[i].coefficient;
    cin>>k2;
    for(int i=0;i<k2;i++)
        cin>>B[i].exponent>>B[i].coefficient;
    for(int i=0;i<k1;i++)
        for(int j=0;j<k2;j++)
            C[A[i].exponent+B[j].exponent]+=A[i].coefficient*B[j].coefficient;
    for(int i=A[0].exponent+B[0].exponent;i>=0;i--)
        if(C[i])k3++;
    cout<<k3;
    for(int i=A[0].exponent+B[0].exponent;i>=0;i--)
        if(C[i])printf(" %d %.1f",i,C[i]);
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章