PTA甲級1065 A+B and C (64bit) (20分)-水題

題目原文

Given three integers A, B and C in [−263,263], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

Thanks to Jiwen Lin for amending the test data.

代碼如下:

#include<cstdio>
#include<iostream>
using namespace std;
int main(void) {
	int k,i=0;
	long long a, b, c,res;
	scanf("%d", &k);
	while (k--) {
		scanf("%lld%lld%lld", &a, &b, &c);
		res = a + b;
		if ((a < 0 && b < 0 && res >= 0)) {
			printf("Case #%d: false\n", ++i);
		}
		else if((a > 0 && b > 0 && res < 0) ){
			printf("Case #%d: true\n", ++i);
		}
		else if ( res > c) {
			printf("Case #%d: true\n", ++i);
		}
		else if (res <= c) {
			printf("Case #%d: false\n", ++i);
		}
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章