PTA-1014 Waiting in Line (30 分)

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer​i​​ will take T​i​​ minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer​1​​ is served at window​1​​ while customer​2​​ is served at window​2​​. Customer​3​​ will wait in front of window​1​​ and customer​4​​ will wait in front of window​2​​. Customer​5​​ will wait behind the yellow line.

At 08:01, customer​1​​ is done and customer​5​​ enters the line in front of window​1​​ since that line seems shorter now. Customer​2​​ will leave at 08:02, customer​4​​ at 08:06, customer​3​​ at 08:07, and finally customer​5​​ at 08:10.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output Specification:

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output:

08:07
08:06
08:10
17:00
Sorry

 題意:模擬銀行排隊,銀行有n個窗口,每個窗口的最大排隊人數爲m,剩餘的人在後面等着,有a個人來辦業務,經過k次詢問,對每次詢問給出客戶辦完業務的時間。銀行八點開始營業,下午五點關門,超過五點辦完的業務都輸出Sorry

#include<iostream>
#include<algorithm>
#include<queue>
#include<cstring>
using namespace std;
int serve_time[1001];
int ans[1001];
queue<int> Q[21];
int main(void)
{
 int w,cap,cus,k;//分別記錄窗口數量、窗口最大人數、顧客數量和查詢數量
 int i,j;
 scanf("%d%d%d%d",&w,&cap,&cus,&k);
  for(i = 1; i <= cus; i ++)
   scanf("%d",&serve_time[i]);
 	int sum = 0;
   int count = 1;
   for(int ti = 0; ti < 540; ti = ti + 1)
   {//以時間來作爲循環,這個很關鍵
   for(i = 0; i < w; i ++)
   {
    for(j = 0; j < Q[i].size(); j ++)
	{
     if(ti == ans[Q[i].front()])
	 {//如果當前隊伍的人服務結束了
      Q[i].pop();
       sum --;
     if(!Q[i].empty())
	  {//並且計算當前隊伍下一個人的結束時間
       int tmp = Q[i].front();
       ans[tmp] = ti + serve_time[tmp];//結束時間爲當前時間+顧客的服務時間
      }
     }
    }
   }
   
   while(sum < w * cap && count <= cus)
   {
    int min = 0;
    for(i = 0; i < w; i++){
     if(Q[min].size() > Q[i].size())
	 {
      min = i;
     }//找到人最少的那個隊伍
     if(Q[min].size() == 0)  
	 	ans[count] = ti + serve_time[count];//如果隊伍沒人則直接開始服務,並且計算結束時間
     if(Q[min].size() < cap && count <= cus)
	 {
      Q[min].push(count);//否則把讓下一個顧客進隊
      count ++;
      sum ++;
     }
    }
   }
  }
 
  for(i = 0; i < k; i ++)
  {
   int query;
   scanf("%d",&query);
   if(ans[query] == 0)
   	puts("Sorry");//值爲0說明沒有被開始服務,只能Sorry
   else
   {
    int hour,min;
    hour = 8 + ans[query] / 60;
    min = ans[query] % 60;
    printf("%02d:%02d\n",hour,min);//把時間轉換爲標準格式並輸出
   }
  }
 return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章