CISCO HSRP工程實例

拓撲圖:

標記:接入層交換機我們標記爲sw1,做熱備的兩臺交換機,左邊的我們標記爲sw2,右邊的標記爲sw3。
說明:我這裏的連線方式和拓撲上的不一樣,具體方式如下:
Switch1 F0/1 <----> Switch2 F0/1
Switch1 F0/2 <----> Switch3 F0/2
Switch2 F0/10 <----> Switch3 F0/10
Switch2 F0/2 <----> Switch4 F0/2
Switch3 F0/1 <----> Switch4 F0/1
Router1 F0/0 <----> Switch4 F0/0

router配置:
Router#show run
Building configuration...

Current configuration : 1023 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 172.16.1.1 255.255.255.0
 duplex auto
 speed auto
!         
interface Serial1/0
 ip address 10.250.34.51 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Serial1/0 2
ip route 192.168.10.0 255.255.255.0 172.16.1.2
ip route 192.168.10.0 255.255.255.0 172.16.1.3
ip route 192.168.20.0 255.255.255.0 172.16.1.3
ip route 192.168.20.0 255.255.255.0 172.16.1.2
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login    
!
!
end

sw1配置:
sw1#show run
Building configuration...

Current configuration : 940 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname sw1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
!
interface FastEthernet0/1
 switchport mode trunk
!         
interface FastEthernet0/2
 switchport mode trunk
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!         
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface Vlan1
 no ip address
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!         
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

sw2配置:
sw2#show run
Building configuration...

Current configuration : 1497 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname sw2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Port-channel1
 switchport mode trunk
!
interface FastEthernet0/0
!
interface FastEthernet0/1
 switchport mode trunk
!
interface FastEthernet0/2
 no switchport
 ip address 172.16.1.2 255.255.255.0
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet0/11
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet0/12
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address 192.168.10.254 255.255.255.0
 standby 1 ip 192.168.10.250
 standby 1 timers 3 50
 standby 1 priority 200
 standby 1 preempt
 standby 1 track FastEthernet0/2 150
!
interface Vlan20
 ip address 192.168.20.254 255.255.255.0
 standby 2 ip 192.168.20.250
 standby 2 preempt
 standby 2 track FastEthernet0/2
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!         
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

sw3配置:
sw3#show run
Building configuration...

Current configuration : 1572 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname sw3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!         
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Port-channel1
 switchport mode trunk
!
interface FastEthernet0/0
!
interface FastEthernet0/1
 no switchport
 ip address 172.16.1.3 255.255.255.0
!
interface FastEthernet0/2
 switchport mode trunk
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet0/11
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet0/12
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address 192.168.10.253 255.255.255.0
 standby 1 ip 192.168.10.250
 standby 1 timers 3 50
 standby 1 preempt
 standby 1 track FastEthernet0/1
!
interface Vlan20
 ip address 192.168.20.253 255.255.255.0
 standby 2 ip 192.168.20.250
 standby 2 priority 200
 standby 2 preempt
 standby 2 track FastEthernet0/1 150
!
ip http server
no ip http secure-server
!
!
!
mac-address-table static 0000.0c07.ac02 interface FastEthernet0/10 vlan 20
!
!
control-plane
!
!
!         
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

sw4我這裏沒有做任何配置,大家可以根據需要在上面作訪問控制列表之類的配置,好了,配置過程中遇到了一些問題,不過最後都解決了,堅持就是勝利啊!
本文出自 “★Beckham~23” 博客,請務必保留此出處http://loveme23.blog.51cto.com/7891/29446
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章