1009 Product of Polynomials (25 分) (*)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

我的代碼:
 

#include <cstdio>

int main() {
    double a[2110] = {0.0} ,b[2110] = {0.0};
    int e,c0,c1,count = 0; //k爲係數,e爲指數,count計數不爲零的倒數項個數
    double k;
    scanf("%d",&c0);
    for(int i=0; i<c0; i++){
        scanf("%d %lf",&e,&k);
        a[e] = k;
    }
    scanf("%d",&c1);
    for(int i =0; i<c1; i++){
        scanf("%d %lf",&e,&k);
        for(int j = 2000;j>=0;j--){
            if(a[j] != 0.0){
                if(b[j+e] == 0) count++;
//                printf("a[j] = %f, j = %d, ",a[j],j);
//                printf(" X  k =%f, e = %d ==",k,e);
                b[j+e] += a[j]*k;
//                printf("b[j+e] = %f, j+e = %d\n",b[j+e],j+e);
                
            }
        }
    }
    printf("%d ",count);
    for(int j = 2010; j>=0; j--){
        if(b[j] - 0.0 > 0.000001){
            printf("%d %.1f",j,b[j]);
            count--;
            if(count != 0){
                printf(" ");
            }
        }    
    }
    
    return 0;
}

 代碼運行的五個測試點裏有一個不能通過,現在不清楚是哪裏的問題,留待觀摩大神的代碼後再重做。有朋友知道問題在哪也可以幫我指出來,多謝

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章