歐拉函數,歐拉篩

The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)

 

Input

There are several test cases. Each line has two integers a, b (2<a<b<3000000).

 

Output

Output the result of (a)+ (a+1)+....+ (b)

 

Sample Input


 

3 100

 

Sample Output


 

3042

歐拉函數的板子題。

有個公式 當 p爲素數時φ(p) = p - 1

若p是a的因子  φ(p * a) = φ(a) * p 否則  φ(p * a) = φ(a) * (p - 1) 這裏的a爲任意數因此p爲素數 p  - 1 = φ(p)

 

#include <queue>
#include <cstdio>
#include <set>
#include <string>
#include <stack>
#include <cmath>
#include <climits>
#include <map>
#include <cstdlib>
#include <iostream>
#include <vector>
#include <algorithm>
#include <cstring>
#include <stdio.h>
#include <ctype.h>
#include <bitset>
#define  LL long long
#define  ULL unsigned long long
#define mod 10007
#define INF 0x7ffffff
#define mem(a,b) memset(a,b,sizeof(a))
#define MODD(a,b) (((a%b)+b)%b)
//#define maxn 50
using namespace std;
const int maxn = 3000010;
int n,m;
int prime[maxn];
int phi[maxn];
int vis[maxn];
void orla(int x)
{
    int index = 0;
    for(int i = 2; i < x; i++){
       if(!vis[i]) {prime[index++] = i;phi[i] = i - 1;}
       for(int j = 0; j < x && i * prime[j] < x; j++){
         vis[i * prime[j]] = 1;
         if(i % prime[j] == 0){
            phi[i * prime[j]] = (phi[i] * prime[j]);
            break;
         }
         else phi[i * prime[j]] = (phi[i] * phi[prime[j]]);
       }
    }
}
void init(int n)
{
   for(int i = 1; i < n; i++){
     phi[i] += phi[i - 1];
   }
}
int main()
{
    int a,b;
    orla(maxn);
    //init(maxn);

    while(~scanf("%d%d",&a,&b)){
           LL sum = 0;
      for(int i = a; i <= b; i++){
        sum+=phi[i];
      }
    printf("%lld\n",sum);
    }



    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章