hdu6666 19年杭電多校賽第八場第10題

Quailty and CCPC
Time Limit: 2000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 206 Accepted Submission(s): 111

Problem Description
Considering the overall difficulty of other problems, we invite Quailty to propose an easy problem for this contest.

Quailty accidentally won both gold medal and silver medal in 2017 CCPC final. The reason is explained as follows. According to the official rule, the number of gold medals was 10% of the number of participating teams, rounded to the nearest integer. This is ambiguous when the fractional part of the result is exactly 0.5. There were 115 participating teams, and the rank of Quailty’s team was 12. The organizer originally decided to round down the number, so there were only 11 gold medals, and Quailty’s team could only win the silver medal. Many people defended him against the organizer, saying that his team deserved a gold medal. Later, the organizer changed to round up the number, and Quailty’s team finally won a gold medal.

Now, give you the scoreboard of a contest and the proportion of gold medal teams, could you determine whether there exists a team, such that they would win a gold medal were the number of gold medals rounded up when the fractional part is exactly 0.5, and silver medal if rounded down?

A team ranks before another if they solved more problems or both teams solved an equal number of problems but they had less penalty time.

(Disclaimer: the background is fictitious and the problem is prepared by Nanjing University ICPC Training Team, not Quailty.)

Input
The first line of input consists of a single integer T (1≤T≤120), denoting the number of test cases.

Each test case starts with a line of two integers n (1≤n≤105), denoting the number of participating teams, and d (0≤d≤9), denoting that the proportion of gold medal teams is 10d%. For the next n lines, each containing a string s and two integers p,t (0≤p,t≤109), denoting the name of the team, the number of problems solved and the penalty time of the team, respectively. The name of the each team contains at least 1 and at most 10 latin letters. The names are case sensitive. No two teams have the same name. No two teams have the same penalty time. The sum of n over all test cases does not exceed 106.

Output
For each test case, print the team name if there exists such team, or print Quailty is very great otherwise. It can be proved that there is at most one such team.

Sample Input
2
5 1
Ace 1000 0
Luffy 999 1
Sabo 998 2
Roronoa 997 3
Sanji 996 4
2 3
You 0 0
I 10 1

Sample Output
Ace
Quailty is very great
題意: 給出n值隊伍的隊名,a題數量和罰時,以及金獎的比例,問是否存在一支隊伍,在原來人數乘比例後人數是.5的情況,如果是,輸出這隻隊伍的名字,否則輸出Quailty is very great。
思路: 對給出的人數和比例進行判斷其人數最後是否含.5,若是,則向上取整,否則輸出Quailty is very great,詳情看代碼和註釋。

#include <bits/stdc++.h>
using namespace std;
const int N = 1e5 + 10;
struct node {
	char s[15];
	int num, time;
}g[N];

bool cmp(node p, node q) {
	if (p.num == q.num) return p.time < q.time;
	else return p.num > q.num;
}

int main() {
	int t, n, tt, num, kk;
	scanf("%d", &t);
	while (t--) {
		double pro;
		scanf("%d%d", &n, &tt);
		for (int i = 0; i < n; i++) {
			scanf("%s%d%d", g[i].s, &g[i].num, &g[i].time);
		}
		// 人數實際是n*tt/10, 這裏爲了判斷是否有小數.5出現,直接去n*tt的餘數作爲判斷依據 
		if (n * tt % 10 != 5) {
			printf("Quailty is very great\n");
			continue;
		}
		sort(g, g + n, cmp);
		num = ceil(n * 0.1 * tt); // 向上取整 
		printf("%s\n", g[num - 1].s);
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章