HDUOJEquations1496(哈希)

Equations

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12220 Accepted Submission(s): 4877

Problem Description
Consider equations having the following form:

ax12+b*x22+cx32+d*x42=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.

Input
The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.

Output
For each test case, output a single line containing the number of the solutions.

Sample Input
1 2 3 -4
1 1 1 1

Sample Output
39088
0

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <memory.h>
using namespace std;
int f1[1000001];
int f2[1000001];
int main()
{
    int i, j, k, sum;
    int a, b, c, d;
    while(scanf("%d %d %d %d", &a, &b, &c, &d) != EOF)
    {
        if(a>0 && b>0 && c>0 && d>0 || a<0 && b<0 && c<0 && d<0)
        {
            printf("0\n");
            continue;
        }
        memset(f1, 0, sizeof(f1));
        memset(f2, 0, sizeof(f2));
        for(i = 1; i <= 100; i++)
        {
            for(j = 1; j<= 100; j++)
            {
                k = a*i*i + b*j*j;
                if(k >= 0) f1[k]++; 
                else f2[-k]++;
            }
        }
        sum = 0;
        for(i = 1; i <= 100; i++)
        {
            for(j = 1; j<= 100; j++)
            {
                k = c*i*i + d*j*j;
                if(k > 0) sum += f2[k]; 
                else sum += f1[-k]; 
            }
        }
        printf("%d\n", 16*sum);
    }
 
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章