Big Christmas Tree

Christmas is coming to KCM city. Suby the loyal civilian in KCM city is preparing a big neat Christmas tree. The simple structure of the tree is shown in right picture.

The tree can be represented as a collection of numbered nodes and some edges. The nodes are numbered 1 through n. The root is always numbered 1. Every node in the tree has its weight. The weights can be different from each other. Also the shape of every available edge between two nodes is different, so the unit price of each edge is different. Because of a technical difficulty, price of an edge will be (sum of weights of all descendant nodes) × (unit price of the edge).

Suby wants to minimize the cost of whole tree among all possible choices. Also he wants to use all nodes because he wants a large tree. So he decided to ask you for helping solve this task by find the minimum cost.

Input

The input consists of T test cases. The number of test cases T is given in the first line of the input file. Each test case consists of several lines. Two numbers ve(0 ≤ ve ≤ 50000) are given in the first line of each test case. On the next line, v positive integers wi indicating the weights of v nodes are given in one line. On the following e lines, each line contain three positive integers abcindicating the edge which is able to connect two nodes a and b, and unit price c.

All numbers in input are less than 216.

Output

For each test case, output an integer indicating the minimum possible cost for the tree in one line. If there is no way to build a Christmas tree, print “No Answer” in one line.

Sample Input

2
2 1
1 1
1 2 15
7 7
200 10 20 30 40 50 60
1 2 1
2 3 3
2 4 2
3 5 4
3 7 2
3 6 3
1 5 9

Sample Output

15
1210

這個似乎看不出來是最短路,可能我還是沒明白最短路的本質

就是每一個樣例,加邊時都要初始化爲0,否則會RE

然後,inf要足夠大,否則會wa

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<queue>
using namespace std;
const int maxn=5e4+10;
#define ll long long
const ll INF=0x3f3f3f3f3f3f3f3f;
bool vis[maxn<<1];ll ans;
ll v,e;ll len;
ll w[maxn];
ll value[maxn];
ll head[maxn];
ll d[maxn]; 
struct node{
	ll v,w,next;
}nod[maxn<<1];
void addedge(ll a,ll b,ll c){
	nod[len].v=b;
	nod[len].w=c;
	nod[len].next=head[a];
	head[a]=len++;
}
void spfa(){
	memset(vis,0,sizeof(vis));
	for(ll i=1;i<=v;i++){
		d[i]=INF;
	}

	queue<ll> q;
	ll u=1;
	q.push(u); d[u]=0;//初始化 
	vis[u]=1;
	while(!q.empty()){
		ll x=q.front();
		q.pop();
		vis[x]=0;
		for(ll i=head[x];i!=-1;i=nod[i].next){
			ll v=nod[i].v; ll w=nod[i].w;
			
				if(d[v]>d[x]+w){
					d[v]=d[x]+w;
					if(!vis[v]){
					q.push(v);
					vis[v]=1;
					}// 
				}
			
		}
	}
	return;
}
int main(){
	int t;
	cin>>t;
	while(t--){
	//	memset(vis,0,sizeof(vis));
		memset(head,-1,sizeof(head));
		
		
	scanf("%lld%lld",&v,&e);
	
	for(int i=1;i<=v;i++){
		scanf("%lld",&w[i]); 
	}
	ll a,b,c;
	len=0; 
	for(int i=1;i<=e;i++){
		scanf("%lld%lld%lld",&a,&b,&c);
		addedge(a,b,c);addedge(b,a,c);
	}
	spfa();
	ans=0;
//	len=0;//初始化 
	for(ll i=2;i<=v;i++){
		if(d[i]==INF){
			ans=INF;
			break;
		}
		else ans+=d[i]*w[i];
	}
	if(ans==INF){
		cout<<"No Answer"<<endl;
	}
	else printf("%lld\n",ans);
	}
	return 0;
} 

建模做題,結束

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章