POJ1274The Perfect Stall

http://poj.org/problem?id=1274

The Perfect Stall

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 30516   Accepted: 13381

Description

Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall.
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible.

Input

The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.

Output

For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.

Sample Input

5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2 

Sample Output

4

Source

USACO 40

二分圖最大匹配模板題。

二分圖講解在我另一篇博客裏(未完成)。

#include <cstdio>
#include <cmath>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstring>
using namespace std;
const int N=210;
int m,n,e;//e邊數,m,n分別爲兩個點集中點的數量
int line[N][N];//map用來存邊 
bool used[N];//在回溯過程中是否已被配對
int ans[N];//最後連接的點
bool found(int x)
{
	for(int i=1;i<=m;i++)
		if(line[x][i]&&!used[i])
		{
			used[i]=1;
			if(!ans[i]||found(ans[i]))
			{
				ans[i]=x;
				return 1;
			}
		}
	return 0;	
} 
int main()
{
	while(~scanf("%d%d",&n,&m))
	{
		int x,y;
		memset(line,0,sizeof(line));
		memset(ans,0,sizeof(ans));
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&x);
			for(int j=0;j<x;j++)
			{
				scanf("%d",&y);
				line[i][y]=1;
			}
		}
		int cnt=0;
		for(int i=1;i<=n;i++)
		{
			memset(used,0,sizeof(used));
			if(found(i))
				cnt++;
		}
		printf("%d\n",cnt);
	}
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章