1027 Larry and Inversions (35 分)(C++)

Larry just studied the algorithm to count number of inversions. He’s very interested in it. He’s considering another problem: Given a permutation of integers from 1 to n, how many inversions it has if we reverse one of its subarray?

Formally speaking, given an integer array a (indices are from 0 to n−1) which contains a permutation of integers from 1 to n, two elements a[i] and a[j] form an inversion if a[i]>a[j] and i<j. Your job is to count, for each pair of 0≤i≤j<n, the number of inversions if we reverse the subarray from a[i] to a[j].

Input Specification:
Each input file contains one test case. Each case consists of a positive integer n (≤1,000) in the first line, and a permutation of integers from 1 to n in the second line. The numbers in a line are separated by a single space.

Output Specification:
For each test case, output n(n+1)/2 integers in a single line. The results are for reversing subarray indicating by all possible pairs of indices 0≤i≤j<n in i-major order – that is, the first n results are for the reverse of subarrary [0…0], [0…1], …[0…n−1]; the next n−1 results are for the reverse of subarry [1…1], [1…2],…, [1…n−1] and so on.

All the numbers in a line must be separated by a single space, with no extra space at the beginning or the end of the line.

Sample Input:

3
2 1 3

Sample Output:

1 0 2 1 2 1

Hint:

The original array is { 2, 1, 3 }.

Reversing subarray [0…0] makes { 2, 1, 3 } which has 1 inversion.
Reversing subarray [0…1] makes { 1, 2, 3 } which has 0 inversion.
Reversing subarray [0…2] makes { 3, 1, 2 } which has 2 inversions.
Reversing subarray [1…1] makes { 2, 1, 3 } which has 1 inversion.
Reversing subarray [1…2] makes { 2, 3, 1 } which has 2 inversions.
Reversing subarrays [2…2] makes { 2, 1, 3 } which has 1 inversion.

題目大意:
求給出一串序列,求其逆序數。但是並不是僅僅求當前這個序列的逆序數,對這串逆序數進行排列組合,輸出各個組合的逆序數,順序按照原序列,進行[0…0], [0…1], …[0…n−1],[1…1], [1…2],…, [1…n−1],…, [n-1…n-1],進行逆置。([i…j]表示將序列i位置到j位置進行逆置)。

解題思路:
最暴力的方法就是對每次組合後的序列求其逆序數。很顯然,爲了降低時間,會想到只是進行一些逆序操作,原序列的逆序數與逆置後的序列的逆序數之間是不是有關係。別說,還真有。

記序列(a1,a2,a3...,ana_{1}, a_{2}, a_{3}...,a_{n})的逆序數爲SS
其子序列(ai,...,aja_{i}, ... ,a_{j}))的逆序數爲TT
則原序列[i,j][i,j] 逆置後序列(a1,....,aj1,aj,....,ai+1,ai,....,ana_{1}, ...., a_{j-1},a_{j}, ...., a_{i+1}, a_{i}, ...., a_{n})的逆序數爲S2T+(ji)(ji+1)/2S - 2 * T + (j-i) * (j-i+1) / 2

現在的問題就成了能不能以儘量少的重複運算計算TT
設置一個二維數組num,大小爲n*n, num[i][j]表示在原序列中因爲aia_{i}的原因而在iji-j的位置產生的逆序數。先要求子序列(ai,...,aja_{i}, ... ,a_{j}))的逆序數TT的話,我們即求num[i][j] + num[i+1][j] + … +num[j][j]

代碼:

#include <bits/stdc++.h>
using namespace std;
int n;
int main(){
	scanf("%d", &n);
	vector<int>v(n);
	vector<vector<int>> num(n, vector<int>(n, 0));
	for(int i = 0; i < n; ++ i)
		scanf("%d", &v[i]);
	int S = 0; #原序列的逆序數
	for(int i = 0; i < n; ++ i){
		int temp = 0;
		for(int j = i; j < n; ++ j){
			if(v[j] < v[i])
				++ temp;
			num[i][j] = temp;
		}
		S += temp;
	}
	for(int i = 0; i < n; ++ i)
		for(int j = i; j < n; ++ j){
			if(i == j){
				if(i != 0)
					printf(" "); #第一個數字前不需要空格
				printf("%d", S);
			}
			else{
				int T = 0;
				#求T大小
				for(int t = i; t < j; ++ t)
					T += num[t][j];
				printf(" %d", S - 2 * T + (j-i) * (j-i+1) / 2);
			}
		}
} 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章