hdu 1398(普通型母函數)

Square Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4675    Accepted Submission(s): 3166


Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland. 
There are four combinations of coins to pay ten credits: 

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin. 

Your mission is to count the number of ways to pay a given amount using coins of Silverland.
 

Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
 

Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output. 
 

Sample Input
2 10 30 0
 

Sample Output
1 4 27
 

Source
 

Recommend
Ignatius.L
 



題目類型:普通型母函數

題目描述:略

題目分析:裸


代碼如下:

#include <stdio.h>
#include <memory.h>
#define N 301

int r[N];
int t[N];

void init(){
    int i,j,k;
    for( i = 0; i < N; i++){
        r[i] = 1;
        t[i] = 0;
    }
    for( k = 2; k <= 17; k++){
        for( i = 0; i < N; i++){
            for( j = 0; j < N; j += k*k) {
                if( r[i] != 0 && i + j < N){
                    t[i+j] += r[i];
                }
            }
        }
        for( i = 0; i < N ; i++){
            r[i] = t[i];
            t[i] = 0;
        }
    }
}



int main()
{
    int x;
    init();
    while(scanf("%d",&x),x){
        printf("%d\n",r[x]);
    }

    return 0;
}


發佈了46 篇原創文章 · 獲贊 1 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章