poj 1611(並查集)

The Suspects
Time Limit: 1000MS   Memory Limit: 20000K
Total Submissions: 14238   Accepted: 6761

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

Source






題目類型:並查集

題目描述:現在有n個人,被分成若干組,一個人可以在多個組。現在有一種傳染病,因爲同組之間的成員交往比較頻繁,所以某組只要一個人患病,那麼認定該組所有人都患病。現在確定0號人已經患病。問你現在有多少人患病。

題目分析:比較裸的並查集。這題雖然是靜態圖,用搜索也可以。但是用並查集寫起來更簡單。

代碼如下:

#include <iostream>
#include <stdio.h>
#define N 30001
using namespace std;

int f[N];
int rank[N];
int n;
int m;

void init(){
    for(int i = 0; i < n; i++){
        f[i] = i;
    }
    memset(rank,0,sizeof(rank));
}

int find(int x){
    if( x == f[x] ) {
        return x;
    } else {
        return f[x] = find(f[x]);
    }
}
void merge(int a,int b){
    int ra = find(a);
    int rb = find(b);
    if( ra != rb ){
        if( rank[ra] < rank[rb]){
            f[ra] = rb;
        } else {
            f[rb] = ra;
            if( rank[ra] == rank[rb]) {
                rank[ra]++;
            }
        }
    }
}

int main()
{
    while(scanf("%d%d",&n,&m), n || m){
        init();
        int k = 0;
        int first = 0;
        int temp = 0;
        for(int i = 0; i < m; i++){
            scanf("%d",&k);
            if( k > 0) {
                scanf("%d",&first);
                for(int j = 1; j <= k-1; j++){
                    scanf("%d",&temp);
                    merge(first,temp);
                }
            }
        }
        int target = find(0);
        int sum = 0;
        for(int i = 0; i < n ;i++){
            if(find(i) == target){
                sum++;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章