POJ 1276

Cash Machine
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 35169   Accepted: 12746

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash. 

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash. 

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

也就是題目要求給定一個金額,在給定n種金額的錢和數量,問,用這些錢能組合的最接近給定金額的數是多少。

這道題是一個多重揹包的模板題,然後加上二分查找即可

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
int dp[1000001];
struct p
{
    int p;
}ch[10001];
int main()
{
    int n,m,c,p;
    while(scanf("%d",&n)!=EOF)
    {
        scanf("%d",&m);
        int i;
        int t=0;
        for(i=1;i<=m;i++)
        {
            int u=1;
            scanf("%d%d",&c,&p);
            while(c)
            {
                if(c-u>=0)
                    c=c-u;
                else
                    u=c,c=0;
                ch[t].p=u*p;
                t++;
                u=u*2;
            }
        }
        memset(dp,0,sizeof(dp));
        for(i=0;i<t;i++)
        {
            for(int k=n;k>=ch[i].p;k--)
            {
                dp[k]=max(dp[k],dp[(k-ch[i].p)]+ch[i].p);
            }
        }
        cout<<dp[n]<<endl;
    }
}


發佈了67 篇原創文章 · 獲贊 100 · 訪問量 14萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章